1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update 10.2.0 --> 10.3.0 Debian lenny

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by UweP, Jul 13, 2011.

  1. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    Plesk 10.3.0 Debian Lenny 64-Bit

    When I upgraded to Plesk 10.3.0 I got an apt-error saying that some file can't be replaced because another package allready provides the file. The file is from libarchive and now I restarted the server, getting the following error:

    The following packages have unmet dependencies:
    libaps: Depends: libarchive but it is not installable
    E: Unmet dependencies. Try using -f.
    master:~# apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
    pwgen jsvc libbreakpoint-ruby1.8 libmime-types-perl libc-client2007b libjaxp1.3-java libcommons-pool-java
    sw-librrd libbcel-java xsltproc libecj-java bind9 sharutils libfile-remove-perl liboro-java libnet-ip-perl
    libcommons-modeler-java libxerces2-java sw-rrdtool libio-stringy-perl debhelper irb1.8 libnet-dns-perl psa-pear
    php5-xsl libcommons-fileupload-java db4.2-util libservlet2.4-java re2c libcmdparse2-ruby1.8 tomcat5.5-webapps
    antlr dnsutils libcommons-beanutils-java bind9utils libmysql-ruby1.8 libnet-xwhois-perl
    pp-sitebuilder-default-templates awstats postfix-pcre libcommons-launcher-java rake libantlr-java-gcj
    php5-sqlite libmocha-ruby1.8 libxslt1.1 po-debconf rdoc xinetd libsqlite0 libredcloth-ruby1.8
    default-jre-headless ecj-gcj libjs-prototype libfcgi-ruby1.8 libcommons-logging-java rails libruby
    intltool-debian libecj-java-gcj tomcat5.5-admin libsqlite3-ruby1.8 libcommons-collections-java
    libxerces2-java-gcj spamc libtomcat5.5-java sun-java6-jdk java-gcj-compat-headless ant gcj-4.3 ruby default-jdk
    ecj psa-courier-imap php5-curl mailman liblog4r-ruby1.8 default-jre ant-optional psa-ftputil gjdoc
    gappletviewer-4.3 libgcj9-dev mlock sw-cp-server libsys-syslog-perl libmx4j-java irb libbuilder-ruby1.8
    libcommons-dbcp-java libapache2-mod-jk libncurses-ruby1.8 libmail-box-perl liberb-ruby libantlr-java
    libcommons-el-java libmmap-ruby1.8 rdoc1.8 java-gcj-compat psa-locale-base-en-us webalizer tomcat5.5
    libservlet2.3-java libdaemons-ruby1.8 libcommons-daemon-java php5-imap libgeoip1 libregexp-java libsocket6-perl
    libgcj9-src fastjar libstruts1.2-java rhino libxml-simple-ruby libdb4.2 rubygems1.8 ant-optional-gcj
    libsasl2-modules-sqlite3 html2text libnetaddr-ip-perl libruby1.8-extras libcommons-collections3-java
    libmail-spf-perl libobject-realize-later-perl libuser-identity-perl libcommons-validator-java sqlite3
    plesk-skins libopenssl-ruby1.8 libmail-sendmail-perl ant-gcj libreadline-ruby1.8 libcommons-digester-java
    java-gcj-compat-dev sw-collectd pp-sitebuilder-skins libsys-hostname-long-perl liblog4j1.2-java
    libcommons-io-java libdigest-hmac-perl liblog4j1.2-java-gcj libfcgi0ldbl python-libxml2 spamassassin
    sw-doctrine libjaxp1.3-java-gcj libio-socket-inet6-perl
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    libaps libpam-plesk plesk-base plesk-core plesk-l10n plesk-mail-pc-driver pp-sitebuilder pp10.10.1-bootstrapper
    pp10.11.0-bootstrapper pp10.12.0-bootstrapper psa psa-awstats-configurator psa-backup-manager psa-firewall
    psa-health-monitor psa-horde psa-imp psa-ingo psa-kronolith psa-logrotate psa-mail-driver-common
    psa-mailman-configurator psa-migration-agents psa-migration-manager psa-mimp psa-mnemo psa-passwd
    psa-php5-configurator psa-proftpd psa-pylibplesk psa-rubyrails-configurator psa-spamassassin
    psa-tomcat-configurator psa-turba psa-updates psa-vhost psa-watchdog sshterm sw-engine
    0 upgraded, 0 newly installed, 39 to remove and 0 not upgraded.
    53 not fully installed or removed.
    After this operation, 470MB disk space will be freed.
    Do you want to continue [Y/n]? n

    The same with apt-get upgrade -f

    Also I get the following error when trying to go to the plesk page:
    ERROR: PleskFatalException
    Components::componentUpdate() failed: Unable to exec utility packagemng: file does not exist or is not executable: /opt/psa/admin/bin/packagemng



    Expected Result is that Plesk updates to 10.3.0 and apt-get doesn't want to remove the plesk packages.

    I have no idea what to do it would be nice if someone could help me.
     
  2. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    The error on the Plesk panel is gone. I did: chmod +x /opt/psa/admin/sbin/wrapper Now the panel works but I still have the problems with apt. Can anyone please help me? :(
     
  3. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    In the Panel itself it says it's still Plesk 10.2.0 but in the Update Manager (Port 8447) it says it's Plesk 10.3.0
     
  4. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    Ok, somehow apt-get -f install shows something else now:


    master:~/psalog# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    libarchive
    The following NEW packages will be installed:
    libarchive
    0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
    53 not fully installed or removed.
    Need to get 0B/121kB of archives.
    After this operation, 299kB of additional disk space will be used.
    Do you want to continue [Y/n]?
    WARNING: The following packages cannot be authenticated!
    libarchive
    Install these packages without verification [y/N]? y
    (Reading database ... 110290 files and directories currently installed.)
    Unpacking libarchive (from .../libarchive_2.8.4-11042015_amd64.deb) ...
    dpkg: error processing /var/cache/apt/archives/libarchive_2.8.4-11042015_amd64.deb (--unpack):
    trying to overwrite `/usr/lib/libarchive.so.2', which is also in package libarchive1
    Errors were encountered while processing:
    /var/cache/apt/archives/libarchive_2.8.4-11042015_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  5. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    I fixed the problem by doing: dpkg -i --force-overwrite AAA where AAA was the package which was going to be installed.
    After this I ran apt-get -f install again and now everything seems to be working. The upgrade process is beeing continued and finished without any additional errors. :)
     
  6. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    Hm there was an error, Error occurred while reading template file /opt/psa/etc/modules/watchdog/monitrc.tpl for the monit service.

    Also the panel shows version 10.2.0 while the update manager still shows 10.3.0. The panel also says that the upgrade failed. the autoinstaller.log says

    Parallels Products Installer 3.10.0 (built on 2011-06-29 12:30 svn rev. 301389) started at (timezone CET) Thu Jul 14 00:19:25 2011
    Command line arguments: /opt/psa/admin/bin/autoinstaller --service-mode --enable-xml-output --ssl-cert /opt/psa/admin/conf/httpsd.pem --web-interface --with-ssl --disable-browser

    SourceUrl: original source url is http://autoinstall.plesk.com/
    SourceUrl: fixed url is http://autoinstall.plesk.com/
    Try to find rcfile...
    Autoinstaller rcfile not found.
    Read component settings from /root/.autoinstaller/options.ini
    Messages::setLocale: try to create object for locale: de-DE.UTF-8
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    FileFetcher: get file (~empty)/PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3
    Datei wird heruntergeladen PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3: 14%..22%..37%..45%..52%..60%..72%..87%..95%..100% fertig.
    No removers section in this build.
    No preferrers section in this build.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    FileFetcher: get file (~empty)/PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3
    Datei wird heruntergeladen PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3: 10%..22%..37%..45%..52%..60%..72%..87%..95%..100% fertig.
    No removers section in this build.
    No preferrers section in this build.
    Messages::setLocale: try to create object for locale: de-DE.UTF-8
    Messages::setLocale: try to create object for locale: de-DE.UTF-8
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    FileFetcher: get file (~empty)/PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3
    Datei wird heruntergeladen PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3: 14%..22%..37%..45%..52%..64%..72%..87%..95%..100% fertig.
    No removers section in this build.
    No preferrers section in this build.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    FileFetcher: get file (~empty)/PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3
    Datei wird heruntergeladen PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3: 14%..22%..37%..45%..52%..60%..72%..87%..95%..100% fertig.
    No removers section in this build.
    No preferrers section in this build.
    Messages::setLocale: try to create object for locale: de-DE.UTF-8
    Messages::setLocale: try to create object for locale: de-DE.UTF-8
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    The SelectBestBuild function has selected the build PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3 for installation.
    FileFetcher: get file (~empty)/PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3
    Datei wird heruntergeladen PSA_10.3.0/plesk-10.3.0-deb5.0-x86_64.inf3: 14%..22%..37%..45%..52%..60%..76%..83%..91%..100% fertig.
    No removers section in this build.
    No preferrers section in this build.
     
  7. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
    My Problem now is that the Panel still says it is 10.2.0 but the update manager webinterface says it's 10.3.0. I removed the .flag file which makes the Panel notify about update failure.
     
Loading...