1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Updated Plesk to 7.5.3 and now Horde is broke!

Discussion in 'Plesk for Linux - 8.x and Older' started by heyandy, Jun 20, 2005.

  1. heyandy

    heyandy Guest

    0
     
    I performed the upgrade from Plesk 7.5.2 to 7.5.3 (through the control panel's Updater option). After the upgrade I know I went to webmail (i.e. Horde) on a couple of my domains and things appeared to work and I got the new interface from Horde. HOWEVER, today when I now goto any of my webmail sites I am getting a Horde error stating the following:

    A fatal error has occurred
    Required 'Array' not specified in DataTree SQL configuration. The file /config/conf.php should contain a $conf['storage']['params']['Array'] setting.
    تم حفظ التفاصيل لمدير النظام

    What the heck gives, and why am I getting Arabic characters on the page? (Actually not that I care, I just need Horde back ASAP.)


    HELP!
     
  2. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    i'v got the same problem, i re-install zend and it solve this.
     
  3. heyandy

    heyandy Guest

    0
     
    Zend

    Ok, I have to ask a dumb question.. But where do I get zend? Is it just an RPM package?
     
  4. poke

    poke Guest

    0
     
    Use yum and ART's channels to upgrade your php and that will include Zend and many other wonderful rpms. www.atomicrocketturtle.com

    -poke

    what's your OS? VPS or not?
     
  5. tripdad

    tripdad Guest

    0
     
    Keep looking you have to move the ioncube_loader files out of your php folder.

    They said Delete them but I moved them to another folder hate deleting stuff I do not know.

    Then restart your apache amd mail services, and start using your new version of horde.

    You will need to log in as root and mv the files.

    /usr/lib/php4 is the directory they are located in on my server, I am running Fedora Core 2.

    I did NOT install Zend nor do I want to install something that is going to use resources that I do not use.

    Hope this helps.

    Dave

    P.S. I found the answer to this a few topics down when he thought his language was changed to hebrew :)
     
  6. voodoochile

    voodoochile Guest

    0
     
    I'd suggest updating your httpd.includes firstbefore screwing with anything else.

    it's a common problem with the 7.5.3 upgrade and has been brought up many many times, a quick forum search for 7.5.3 and horde should show you about 20 threads with this, including the thread I posted last week which included the fix.

    I'm not sure where the websrvm binary will be at on your psa install, FreeBSD stores it on /usr/local/psa/bin/websrvmng, just run it with the -a switch and you'll be straight.
     
  7. heyandy

    heyandy Guest

    0
     
    Fixed!

    Thanks for all the info...
    Tripdad's suggestion did fix my problem. I moved the ioncubeloader* files out of the php folder and it appears Horde is back!

    Thanks for the help!
     
Loading...