1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade broke SMTP

Discussion in 'Plesk for Linux - 8.x and Older' started by CBiLL, Jun 26, 2006.

  1. CBiLL

    CBiLL Guest

    0
     
    I upgraded to 8.0.1 and it broke the SMTP so I can't firgue out what is broken on it becasue it starts up fine but I know it broken becasue I am not getting any emails from outside sources and if I tried to use Horde to send out email it says

    There was an error sending your message: Failed to connect to localhost:25 [SMTP: Invalid response code received from server (code: -1, response: mtpd: 127.0.0.1 pid 14156: 451 Your mail has been rejected because the server you are sending to is misconfigured)]


    Anyone know what might be broken?

    Thank you
    Bill
     
  2. CBiLL

    CBiLL Guest

    0
     
    Never mind..

    I fixed it by going into plesk and saved the server email setting again.

    It reconfigured it and smtp started working again.

    Phew!


    Bill
     
  3. CiViX

    CiViX Guest

    0
     
    I had the same problem, but fixed it by just restarting xinetd after the upgrade was finished:

    /etc/init.d/xinetd restart

    I also had to add -Rt0 to /etc/xinetd.d/smtp_psa like this:
    server_args = -Rt0 /usr/sbin/rblsmtpd etc.....
    which the update removed.

    Seems as if the update also commented out my ioncube-loader from php.ini... strange.
     
  4. DCNet_James

    DCNet_James Guest

    0
     
    I saw this exact problem on FreeBSD, a simple restart of inetd or reboot of the server fixed the problem. Also just to add on to this I simply place a few lines in the psa rc scripts to stop/start/restart inetd right after named. Of course any time theres an update to PSA I have to go in and replace these couple of lines, but it definitely helps. I've also noticed that if inetd is left running even if qmail is down it still accepts port 25 connections and hangs, though not sure if this is still the case. I just ensure that inetd is shutdown any time PSA is down, keeps everyone out while I'm doing maintenance.

    Thx
    James
     
Loading...