• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Upgrade error from 8.6 to 9.x

P

pgudge

Guest
Can anyone help!

I recently updated from 8.2 to 8.6 (updating ever version step by step) and all has gone well.

I have tried to update 8.6 to 9.0.0 to 9.5.2 but they all fail. The last lot of logs from the failure are:

Starting installation of packages
Warning: unresolved requires 'libcrypto.so.6' from psa-qmail-1.03-cos5.build86080930.08.i586
Warning: unresolved requires 'libmysqlclient.so.15' from psa-qmail-1.03-cos5.build86080930.08.i586
Warning: unresolved requires 'libmysqlclient.so.15(libmysqlclient_15)' from psa-qmail-1.03-cos5.build86080930.08.i586
Warning: unresolved requires 'libssl.so.6' from psa-qmail-1.03-cos5.build86080930.08.i586
Warning: unresolved requires 'rtld(GNU_HASH)' from psa-qmail-1.03-cos5.build86080930.08.i586
Warning: unresolved requires 'desktop-file-utils >= 0.9' from redhat-menus-3.8-1.noarch
Installing the package psa-hotfix3-9.0.0-9.0.0-fc4.build90081208.07.i586, psa-9.0.0-fc4.build90081117.17.i586, psa-libpam-plesk-9.0.0-fc4.build90081117.17.i586, psa-mail-qc-driver-1.0.0-fc4.build90081222.11.i586, psa-locale-base-en-US-9.0.0-08111414.noarch, psa-api-9.0.0-fc4.build90081208.07.noarch, plesk-skins-9.0.0-0.278956.noarch, psa-firewall-1.0.1-fc4.build90081117.17.i586, psa-migration-manager-9.0.0-fc4.build90081208.07.i586, psa-watchdog-2.0.3-fc4.build90081117.17.i586, psa-backup-manager-9.0.0-fc4.build90081208.07.i586, psa-api-rpc-9.0.0-fc4.build90081208.07.noarch, cs-gs-2.0.0-fc4.build90081117.17.i586, psa-updates-9.0.0-fc4.build90081222.11.noarch, psa-mail-driver-common-9.0.0-fc4.build90081222.11.i586, psa-hotfix4-9.0.0-9.0.0-fc4.build90081222.11.i586
file /var/qmail/bin/cmd5checkpw from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build84080425.21
file /var/qmail/bin/relaylock from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build84080425.21
file /var/qmail/bin/smtp_auth from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build84080425.21
file /var/qmail/bin/cmd5checkpw from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-cos5.build86080930.08
file /var/qmail/bin/matchup from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-cos5.build86080930.08
file /var/qmail/bin/relaylock from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-cos5.build86080930.08
file /var/qmail/bin/smtp_auth from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-cos5.build86080930.08
file /var/qmail/bin/cmd5checkpw from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build86080930.03
file /var/qmail/bin/relaylock from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build86080930.03
file /var/qmail/bin/smtp_auth from install of psa-mail-qc-driver-1.0.0-fc4.build90081222.11 conflicts with file from package psa-qmail-1.03-fc4.build86080930.03
- Hide quoted text -
Error: Unable to install the requested packages because either there is
not enough free disk space left, or there are package dependency problems.
Warning! Not all packages were installed.
Please check if your system services are operable.
Please, contact product technical support.

Current server is

Operating system Linux 2.6.16.33-061227b
Plesk Control Panel version psa v8.6.0_build86080930.03 os_FedoraCore 4

Thanks for any info

EDIT: I've fixed the imap issue.
And since this last update to 8.6 it seems to have broke my imapd service. The service runs, but refuses connection, the logs show

Aug 20 14:07:27 servername imapd: Invalid -maxprocsarg option.
Aug 20 14:07:27 servername imapd-ssl: Invalid -maxprocsarg option.

So I need to update fast to see if it fixes it :(
 
Last edited by a moderator:
Back
Top