1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Upgrade MySQL and PHP in Plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by FrzzMan, Oct 16, 2005.

  1. FrzzMan

    FrzzMan Guest

    0
     
    My server come with Plesk 7.5.4 Reloaded and PHP 4.3 and MySQL 3.2

    I want to upgrade PHP to 4.4 and MySQL to 4.0, how can I do that?

    I can't found anything related to upgrade software in Plesk.

    Thanks
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you read or search on PHP 4.4, you will see some recent posts where there are some issues upon upgrading to 4.4

    MySQL 4.0.xx is not a problem with Plesk 7.5.3 or 7.5.4 depending on where you get your upgrade from ...

    One great source for Plesk friendly upgrades is ART's yum repository, but if you read his forum on PHP, there are still a few issues with 4.4, Horde being one of them. Some people post like it's his problem, when it may actually be the version of Horde they are using. I use his mySQL 4.0.xx on all my servers without any problems.

    ART (AtomicRocketTurtle) is THE guru on making things work with Plesk. He is also THE guru on Linux Security and many other things too! See his site:

    http://www.atomicrocketturtle.com

    Although I have the latest Horde 3.0.5 I am still reluctant to upgrade PHP to 4.4 until I am sure there won't be any other problems.
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I just re-read the post on ART's site and it seems that (at least for one person) all is well with his upgrade to PHP 4.4 (he found a resolution to his Horde problem).
     
  4. FrzzMan

    FrzzMan Guest

    0
     
    I use CentOS 3.3 and when I added this to the /etc/yum.conf

    [atomic]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/art/$releasever/
    baseurl=http://www.atomicrocketturtle.com/atomic/art/$releasever/

    Then run:

    yum update mysql

    It spilt out error:

    retrygrab() failed for:
    http://www.atomicrocketturtle.com/atomic/art/3.3/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://www.atomicrocketturtle.com/atomic/art/3.3/headers/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found

    About PHP 4.4 and MySQL 4.0, my most important software on the server need them, so maybe I have to sacrifice anything else :(
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
  6. FrzzMan

    FrzzMan Guest

    0
     
    Hmm, yum will update MySQL directly to 4.1.x

    I know that 4.1.x of MySQL will use new password hashing algorythm so I won't compatible with older clients anymore.

    Anyway to update MySQL to 4.0 and not 4.1?
     
  7. poke

    poke Guest

    0
     
    what kind of applications are you running?
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
  9. FrzzMan

    FrzzMan Guest

    0
     
    I run eZ publish 3.7 which require PHP 4.4.0 to work.

    About the MySQL 4.0.x I don't want to encounter any password hashing error... etc... so if there's a way that enable MySQL to accept old password I'll install it.

    Thanks for the link, jamesyeeoc.

    PS: yum works now, btw when trying to do:

    conflict between spamassassin and psa-spamassassin

    Error happens...
     
  10. poke

    poke Guest

    0
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I believe you have to uninstall the psa-spamassassin (2.6.x) before installing ART's SA (which should be 3.x), they don't play well together... at all.
     
  12. FrzzMan

    FrzzMan Guest

    0
     
    Thank you all :D

    I installed PHP 4.4.0 and MySQL 4.1.14 (added old_passwords=1 into my.cnf)

    Everything running fine til now :)
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Did you also do as Poke posted:

    mysql_fix_privilege_tables --user=admin --password=`cat /etc/psa/.psa.shadow`

    ??

    This is not Plesk specific, but is mysql specific when upgrading from 3.23 to 4.x.x, as per the mysql.org site....!
     
  14. FrzzMan

    FrzzMan Guest

    0
     
    Yeah, Plesk cry out some kind of MySQL error after I update MySQL to 4.1.14 but I do some Googling and found out that I have to do that in order to properly update MySQL.

    Better try to find the solution first, I learn things faster that way :)

    Thank you again.
     
  15. koolnyze

    koolnyze Guest

    0
     
    Hello,

    I have successfully upgraded the mysql to 4.1.15 using ART.

    I have installed phpmyadmin on one of domains from where I can view all the databases but the problem is that listing of all databases is available to all the users even though he can only access his database only. Is there a way to prevent listing of all databases to all the users?

    Thanks
     
  16. liquorvicar

    liquorvicar Guest

    0
     
    koolnyze - I had the same problem. For some reason it had GRANTed all my users GLOBAL privileges to create LOCKS and TEMP tables. When I removed these, it went back to how it should.
     
  17. imakalic

    imakalic Guest

    0
     
    hi,

    ive recently tried upgrading my php with yum in centos 3.3 with plesk 7.5.4

    everything works except mysql dies completly
    cannot start it up.
    does anyone have any ideas why this happens?

    upgrading php 4.3.2 to latest yum
    and mysql 3.2.32 again to latest yum

    ive modified my yum.conf with both 3ES/4ES as on his website but only 3ES will update. well thats expected however it kills mysql.

    meh :(

    thanks in advnace for any help.
     
  18. liquorvicar

    liquorvicar Guest

    0
     
    What version of PHP have you upgraded to? Did you install/upgrade php-mysql as well?
     
  19. imakalic

    imakalic Guest

    0
     
    umm yum just upgraded php and mysql together to whatever is the latest now

    the mysql deamon cant be started up anymore afterwards.

    its a vps and ive already reinstalled it in the hope of using the CentOs yum repos
    but they all contain old versions of everything. :(

    dont worry about it. thanks anyway

    im going to move onto a managed solution as this is not for me. too much trouble

    meh :rolleyes:
     
Loading...