1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

upgrading to mod_perl 2.x

Discussion in 'Plesk for Linux - 8.x and Older' started by Stephan2, May 31, 2007.

  1. Stephan2

    Stephan2 Guest

    0
     
    I'm on a VPS using Plesk 8.1 on Centos 4.x. It's currently using mod_perl 1.9.x.

    Is there a way to upgrade to mod_perl 2.0 without breaking Plesk?

    Thanks!
    -Stephan
     
  2. CBiLL

    CBiLL Guest

    0
     
    In same boat here .. at 1.9 and would like to upgrade to 2.0 due to the Apache ASP module complaining deps is missing and 2.0 mod_perl have those missing modules needed.

    I tried upgrading the mod_perl but back off when it told me I need to remove the previous 1.9 version first before I could upgrade and it would remove lots of psa package along with it so I wasn't sure if I could restore those psa packages after the upgrade either.

    If you managed to figure out how to upgrade via yum I would like to learn about it.


    Thanks
    Bill
     
  3. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    The CentOS Plus repository for CentOS 4 has mod_perl 2.0.3. You could enable CentOS Plus and yum update to that. http://mirror.centos.org/centos-4/4.5/centosplus/

    Enabling CentOS Plus is maybe not officially supported by SWsoft, so don't blame me when Plesk breaks somewhere along the road due to this.
     
Loading...