1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

uploading to plesk server connection dropped after 4012 bytes

Discussion in 'Plesk for Linux - 8.x and Older' started by funkyade, Sep 20, 2005.

  1. funkyade

    funkyade Guest

    0
     
    Hi,

    I'm getting some bizarre behaviour from my server. When uploading a file using an FTP or SCP client, i.e winSCP, Smartftp etc... I am getting the following error (or similar) -

    Network error: Software caused connection abort

    :-(

    and I get 4012 bytes of a file uploaded. I've gone through all the client software and I do not get the same problem on any other server. The server does however, 'wget' files when I login using SSH from another server completely fine.

    I am completely baffled by this. Does anyone have any ideas what the problem may be? First noticed after upgrading plesk to 7.5.4, but not certain it was straight after.

    Any pointers to a solution would be great!!!!!
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    These values are not necessarily optimal for all servers, just an example. Depending on how big of an attachment you wish to allow your users, you may want to play with the exact values of these. Change these values in the file:

    /etc/php.ini

    Note: these values can also help those having problems with upload scripts and size limitations as well.

    Originally posted at:
    http://forums.sw-soft.com/showthread.php?threadid=26079&highlight=uploadmaxfilesize
     
  3. funkyade

    funkyade Guest

    0
     
    thanks for that. however, I am aware of the upload size limit under php especially for horde. unfortunately this isn't quite the problem i am having. (settings in php.ini are to allow 80M file uploads btw.)

    I'm trying to establish why either the connection is reset or a file transfer is abandoned after 4012 bytes, leaving an incomplete file on the server when using an SCP or FTP client on a windoze machine.

    cheers...
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Sorry I mis-read your post, no reason to be :mad:

    I do recall some other threads which were the same symptom as you report. Some were attributed to the Windows XP Firewall, others were due to their ISP using a dynamic proxy mechanism (anti-spam measure) on their connection (without informing them) which caused their sessions to change, there were also some who had to switch ProFTP to standalone mode instead of running it under xinetd. Also saw something about quota limits as well (mishandling of quotas by Plesk)

    I have also read on other (non-Plesk) forums that some newer McAfee and Norton products were interfering with FTP (same error).

    These may not resolve your particular situation, just posting what I have seen others do in the same situation.

    From SmartFTP site:
    They recommend checking and setting the "Tools > Settings > Connection > Connection Settings -> "Connection Timeout" to a higher value (default 30 sec)"
     
  5. funkyade

    funkyade Guest

    0
     
    further update...

    The problem seems to be more widespread than just simply uploading files. It is now impossible to send attachments in emails that are over 4k!

    Could this be a problem with the settings on the server firewall, or network interface?

    Any further ideas greatly appreciated.

    the things I have tried so far :

    - changing proftpd to standalone mode didn't make any difference.

    - changing the settings in my client FTP/SCP software re: timeouts etc... hasn't made any difference.

    - not sure how to go about checking ISP proxy... as far as I know there isn't one. (using NTL cable broadband in UK)

    - I don't think it is a quota problem either as it is server wide and there are a mixture of accounts on the server some with quotas some not.

    ! cheers !
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If possible, try uploading from another ISP connection (not NTL) and see if you get different results. You can email me details and I can try it from my connections here if you would like. j a m e s y e e o c at y a h o o . c o m
    Doesn't sound like a firewall issue, but if you have a bad NIC it may be possible, although it's not a common occurance.
    Other than making sure your workstation is free from trojans/worms/spyware/adware, I don't have anything further in mind right now.
     
  7. funkyade

    funkyade Guest

    0
     
    May have solved the problem...

    Rebooted the server, then manually restarted networking (/etc/init.d/network restart), iptables, netplugd. And hey presto I have managed to upload a file of 50K!!!!

    Haven't yet tried with bigger files but I have a couple of sites to upload, which have some big files on them so will edit this post later dependent on result.

    still haven't worked out why this problem was there in the first place though...

    thanks for help.
     
Loading...