1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Urgent! not getting emails

Discussion in 'Plesk for Linux - 8.x and Older' started by modom, Jan 25, 2005.

  1. modom

    modom Guest

    0
     
    Hi,

    I installed clamav from Art's and all went well. Then, when I installed qmail-scanner I get this message and I can send emails now but cannot receive any and there is no mail in the webmail when testing.

    [root@godslove etc]# yum install qmail-scanner
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: Atomic Rocket Turtle
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: Atomic Rocket Turtle
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    ..Dependencies resolved
    I will do the following:
    [install: qmail-scanner 1:1.24-1.rhel3.art.noarch]
    I will install/upgrade these to satisfy the dependencies:
    [deps: perl 3:5.8.5-9.rhel3.art.i386]
    [deps: maildrop 1.6.0-1.rhel3.art.i386]
    [deps: perl-suidperl 3:5.8.5-9.1.rhel3.art.i386]
    [deps: daemontools 0.70-1.rhel3.art.i386]
    [deps: tnef 1.2.1-1.rhel3.art.i386]
    Is this ok [y/N]: y
    Downloading Packages
    Getting perl-5.8.5-9.rhel3.art.i386.rpm
    perl-5.8.5-9.rhel3.art.i3 100% |=========================| 13 MB 00:11
    Getting maildrop-1.6.0-1.rhel3.art.i386.rpm
    maildrop-1.6.0-1.rhel3.ar 100% |=========================| 274 kB 00:00
    Getting perl-suidperl-5.8.5-9.1.rhel3.art.i386.rpm
    perl-suidperl-5.8.5-9.1.r 100% |=========================| 101 kB 00:00
    Getting daemontools-0.70-1.rhel3.art.i386.rpm
    daemontools-0.70-1.rhel3. 100% |=========================| 42 kB 00:00
    Getting qmail-scanner-1.24-1.rhel3.art.noarch.rpm
    qmail-scanner-1.24-1.rhel 100% |=========================| 265 kB 00:00
    Getting tnef-1.2.1-1.rhel3.art.i386.rpm
    tnef-1.2.1-1.rhel3.art.i3 100% |=========================| 42 kB 00:00
    Running test transaction:
    Test transaction complete, Success!
    perl 100 % done 1/9
    maildrop 100 % done 2/9
    perl-suidperl 100 % done 3/9
    tnef 100 % done 4/9
    daemontools 100 % done 5/9
    qmail-scanner 100 % done 6/9
    install: cannot stat `qmail-scanner-queue.pl': No such file or directory
    setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
    setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
    chmod: failed to get attributes of `/var/qmail/bin/qmail-scanner-queue.pl': No such file or directory
    Completing update for perl - 7/9
    Erasing: perl-CGI 8/9
    Erasing: perl-DB_File 9/9
    Installed: qmail-scanner 1:1.24-1.rhel3.art.noarch
    Dep Installed: perl 3:5.8.5-9.rhel3.art.i386 maildrop 1.6.0-1.rhel3.art.i386 perl-suidperl 3:5.8.5-9.1.rhel3.art.i386 daemontools 0.70-1.rhel3.art.i386 tnef 1.2.1-1.rhel3.art.i386
    Transaction(s) Complete

    I am on centOS 3.4 and plesk 7.5.1 reloaded.
     
  2. CBiLL

    CBiLL Guest

    0
     
    Did you run this after installing the qmail scanner?

    /usr/bin/qmail-scanner-reconfigure


    Bill
     
  3. modom

    modom Guest

    0
     
    No but I will now.
     
  4. modom

    modom Guest

    0
     
    [root@godslove root]# /usr/bin/qmail-scanner-reconfigure
    Configuring qmail-scanner: install: cannot stat `qmail-scanner-queue.pl': No such file or directory
    setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
    setuidgid: fatal: unable to run /var/qmail/bin/qmail-scanner-queue.pl: file does not exist
    chmod: failed to get attributes of `/var/qmail/bin/qmail-scanner-queue.pl': No such file or directory
    OK

    How do I remove the qmail scanner so the mail will work again?
     
  5. modom

    modom Guest

    0
     
    I found it...

    yum remove qmail-scanner

    It is working now. This is a first with yum.
     
  6. CBiLL

    CBiLL Guest

    0
     
    Did you get the qmail scanner from Art?

    And how did you install it? if you use Yum it's

    yum remove qmail-scanner

    or you install it as a package then it's

    rpm -e (qmail-scanner package name)


    I would use Art's qmail scanner using the yum install if you gotten your qmail scanner from a different source since Art's works in conjuction with Plesk's qmail ..

    Bill
     
  7. modom

    modom Guest

    0
     
    Hi,

    I got both the clamav and the qmail-scanner from Art's.

    When I uninstalled qmail-scanner the mail started working again.
     
  8. netdias

    netdias Guest

    0
     
    Hello

    Is the rhel3 distribution compatible with centos OS ?
     
  9. k.satirli

    k.satirli Guest

    0
     
    I've got a similar problem..

    I installed qmail-scanner / SA / clamav / clamav-devel

    and ran the reconfigure script but all its doing is:

    Configuring qmail-scanner:

    That's all. Nothing happening except server load going up.

    I thought the reconfigure script was automatically doing everything? whereever I looked, I couldnt find anything about how to handle this situation.

    anyone got pointers? as in ... right now?

    [EDIT]

    I did as suggested in http://www.grafxsoftware.com/util/PLESK-HOWTO.txt

    I also had a look at /var/spool/qmailscan/qmail-queue.log

    and it seems that clamav is running and doing its job, but in the other SSH window, it's still saying

    Configuring qmail-scanner:

    and nothing's happening...
     
Loading...