1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Using Backup with FTP Repository

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by zeroday, Jan 20, 2009.

  1. zeroday

    zeroday Basic Pleskian

    23
    57%
    Joined:
    Jan 20, 2009
    Messages:
    34
    Likes Received:
    0
    is it possible to use another port for the FTP repository other than port 21

    As I have multiple FTP's running I cannot run it on port 21

    when I try mydomain.com:2121 in the webinterface of plesk no error is seen but it will not upload the data
    it's directly failed with
    <message severity="error" code="msgtext">Unable to parse options: Bad FTP file format at /usr/local/psa/admin/bin/plesk_agent_manager line 293.

    when using on port 21 it's working but than it's on the incorrect ftp <sigh>

    How can I accomplish this?
     
  2. VyReN

    VyReN Guest

    0
     
    Same here -- Any ideas from anyone? I guess it may be time to peek around that source code again.
     
  3. VyReN

    VyReN Guest

    0
     
    Good news - this is correctable.
    Bad news - this almost certainly will affect some other part of FTP backups....maybe. I have had no troubles as of yet, but only fired a few backups manually.

    You're going to need shell access, and edit:
    /usr/local/psa/admin/bin/plesk_agent_manager

    On line 266 make it look like this:

    if ($outputFile =~ /^ftp:\/\/(?:([^:mad:]*)(?::([^:]*))?@)?([^\/@]+)\/(.*?)([^\/]*?)$/) {

    All that is removed is a colon :)), about 62 characters in.

    This is breaking part of the verification that this is a valid FTP session, so I have no idea what may happen if you enter invalid FTP server information....
     
Loading...