1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Using Shell_exec in Plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by Jamai, Dec 18, 2004.

  1. Jamai

    Jamai Guest

    0
     
    I noticed that I cannot use shell_exec in Plesk because safe_mode is on. When I turn it off, it works.

    My script looks like this:
    PHP:
    <?
    echo 
    shell_exec('uptime');
    ?>
    When I add
    PHP:
    ini_set("safe_mode",0);
    It just won't work

    I also tried it using /home/httpd/vhosts/mydomain.com/conf/vhost.conf:

    This also won't work, I restarted Apache but no changes. I don't want to change this setting for the complete webserver, only for this domain.

    Does anyone know how I can do this?
     
Loading...