1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

vhost.conf not included in httpd.include

Discussion in 'Plesk for Linux - 8.x and Older' started by pdaehnert, Oct 11, 2007.

  1. pdaehnert

    pdaehnert Guest

    0
     
    hi,

    running a Plesk 8.2 on a Suse Linux 10.1
    im trying to change php settings in my domain by adding a vhost.conf in the directory /conf as it should be...

    unfortunately, after executing the command ##/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=peteranne.de###
    the vhost.conf is not included in the end of the httpd.include

    i cannot see that im doin anything wrong because it is working perfectly for a different domain on the same server

    restarting the apache server doesnt change anything either - this is to expect as vhost.conf is was not included before....

    these are the 2 files:


    vhost.conf:
    ##############
    php_admin_flag safe_mode OFF
    php_admin_value upload_max_filesize 20M
    php_admin_flag magic_quotes_gpc ON
    ##############

    httpd.include
    ##############
    # ATTENTION!
    # DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
    # FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
    # MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
    # FOLLOWING FILE(S):
    # /srv/www/vhosts/peteranne.de/conf/vhost.conf
    # /srv/www/vhosts/peteranne.de/subdomains/<subdomain-name>/conf/vhost.conf

    <VirtualHost 81.169.169.198:80>
    ServerName peteranne.de:80
    ServerAlias www.peteranne.de
    UseCanonicalName Off
    SuexecUserGroup pdaehnert psacln
    DocumentRoot /srv/www/vhosts/peteranne.de/httpdocs
    CustomLog /srv/www/vhosts/peteranne.de/statistics/logs/access_log plesklog
    ErrorLog /srv/www/vhosts/peteranne.de/statistics/logs/error_log
    <IfModule mod_userdir.c>
    UserDir /srv/www/vhosts/peteranne.de/web_users
    </IfModule>
    ScriptAlias /cgi-bin/ /srv/www/vhosts/peteranne.de/cgi-bin/
    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>
    <Directory /srv/www/vhosts/peteranne.de/httpdocs>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/httpdocs:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/httpdocs:/tmp"
    </IfModule>
    Options +Includes +ExecCGI
    </Directory>
    <Directory /srv/www/vhosts/peteranne.de/web_users>
    <IfModule sapi_apache2.c>
    php_admin_flag engine off
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_flag engine off
    </IfModule>
    </Directory>
    </VirtualHost>

    <VirtualHost 81.169.169.198:80>
    ServerName gescheiterte.peteranne.de:80
    SuexecUserGroup pdaehnert psacln
    DocumentRoot /srv/www/vhosts/peteranne.de/subdomains/gescheiterte/httpdocs
    CustomLog /srv/www/vhosts/peteranne.de/statistics/logs/access_log plesklog
    ErrorLog /srv/www/vhosts/peteranne.de/statistics/logs/error_log
    ScriptAlias /cgi-bin/ /srv/www/vhosts/peteranne.de/subdomains/gescheiterte/cgi-bin/
    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>
    <Directory /srv/www/vhosts/peteranne.de/subdomains/gescheiterte/httpdocs>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/subdomains/gescheiterte/httpdocs:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/subdomains/gescheiterte/httpdocs:/tmp"
    </IfModule>
    Options +Includes +ExecCGI
    </Directory>
    </VirtualHost>

    <VirtualHost 81.169.169.198:80>
    ServerName rdaehnert.peteranne.de:80
    SuexecUserGroup rdaehnert psacln
    DocumentRoot /srv/www/vhosts/peteranne.de/subdomains/rdaehnert/httpdocs
    CustomLog /srv/www/vhosts/peteranne.de/statistics/logs/access_log plesklog
    ErrorLog /srv/www/vhosts/peteranne.de/statistics/logs/error_log
    ScriptAlias /cgi-bin/ /srv/www/vhosts/peteranne.de/subdomains/rdaehnert/cgi-bin/
    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>
    <Directory /srv/www/vhosts/peteranne.de/subdomains/rdaehnert/httpdocs>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/subdomains/rdaehnert/httpdocs:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/srv/www/vhosts/peteranne.de/subdomains/rdaehnert/httpdocs:/tmp"
    </IfModule>
    Options +Includes +ExecCGI
    </Directory>
    </VirtualHost>
    ###########
     
  2. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    should be in the last line
    Code:
            </Directory>
            Include /var/www/vhosts/<domain>/conf/vhost.conf
    </VirtualHost>
    
     
  3. pdaehnert

    pdaehnert Guest

    0
     
    include

    yes it should be....thats the include i mentionend.

    you cannot add this manualy, it has to be included by executing the "websrvmng -rreconfigure vhost" thing....


    but that doesnt work and THAT is my problem
     
  4. j_kev@

    j_kev@ Guest

    0
     
    Try to use follow command

    "websrvmng --reconfigure-vhost --vhost-name=<domain_name>"

    I'll check it and it's well. :cool:
     
  5. pdaehnert

    pdaehnert Guest

    0
     
    i know this command and it worked for a different domain but NOT for that domain.
     
  6. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    Re: include

    Its not so much that you cant , its just that in good practice you shouldnt.

    you can try doing the -a --reconfigure-all param option. If this is the only domain where its not taking effect then you can just add it manually - if the customer will not be changing httpd settings you can also do a chattr +i on the file so that plesk can not overwrite your changes.

    Kind of a last resort, but it will work.
     
Loading...