1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

vhost.conf with ServerAlias but no redirect

Discussion in 'Plesk for Linux - 8.x and Older' started by carnalito, Oct 30, 2005.

  1. carnalito

    carnalito Guest

    0
     
    Hi there,

    i have searched for an old Problem to use one webspace with several domainnames.

    I found a solution in creating a vhost.conf with the ServerAlias Directive. I have loaded the new config via:
    /usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com
    Restarted apache and checked the domain...

    No redirection, just the Placeholder index.html of the domain.com webspace.

    Any help would be appreciated !

    Regards

    Carnalito
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    You should post what exactly you have put into the vhost.conf file so others can see if there are any changes which need to be made..

    Also, have you pointed the 2nd domain to the main domain's IP?

    Personally, I use the following command:

    /usr/local/psa/admin/bin/websrvmng -u --vhost-name=domain.com

    some of their options don't always work properly.

    Have you uploaded an index file to the main domain's docroot?
     
  3. carnalito

    carnalito Guest

    0
     
    Try to answer correctly, i want to point domain.com to domain.de wich is the maindomain:
    ServerAlias www.domain.de
    ServerAlias domain.de

    Yes it do, the PlaceHolderIndexFile from Plesk is shown.

    I have tried this also with the same result.

    No, i created a virtual hosting with webspace and i think the page is created automatically ?!

    Hope to be helped !

    Thanks

    carnalito
     
  4. carnalito

    carnalito Guest

    0
     
    any help ?!

    Regards

    Carnalito
     
  5. carnalito

    carnalito Guest

    0
     
    After trying all different stuff i found the fault (dumb carnalito):

    I have done this all in the wrong place. I placed the vhost.conf in the webspace of the domain wich should be redirected.
    But in real life the 'ServerAlias' Directive should be placed in the webspace of the target-domain.

    I posted this just in case someone also failed.

    Regards

    Carnalito
     
Loading...