1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Warnings and Errors !

Discussion in 'Legacy Sitebuilder Software' started by eddie69, Dec 21, 2004.

  1. eddie69

    eddie69 Guest

    0
     
    Hi,
    Does anybody have any idea why I am getting these errors when accessing SiteBuilder.

    Warning: main(): open_basedir restriction in effect. File(./page_header.php) is not within the allowed path(s): (/home/httpd/vhosts/yely.com/httpdocs:/tmp) in /usr/local/sitebuilder/towizard.php on line 7
    Warning: main(page_header.php): failed to open stream: Operation not permitted in /usr/local/sitebuilder/towizard.php on line 7
    Warning: main(): open_basedir restriction in effect. File(./page_header.php) is not within the allowed path(s): (/home/httpd/vhosts/yely.com/httpdocs:/tmp) in /usr/local/sitebuilder/towizard.php on line 7
    Warning: main(page_header.php): failed to open stream: Operation not permitted in /usr/local/sitebuilder/towizard.php on line 7
    Fatal error: main(): Failed opening required 'page_header.php' (include_path='.:/usr/share/pear') in /usr/local/sitebuilder/towizard.php on line 7

    If I refresh the browser about 20 times it finally allows you to do some work and then I'll get the same error over again.
    Using Fedora 1
    Plesk reloaded 7.5
    Thanks!
     
  2. Mr. Pink

    Mr. Pink Guest

    0
     
    Hi Eddie,

    Does this error happen occasionally or permanently? From your description I asume occasionally ...

    Sitebuilder does have its own vhost (/etc/httpd/conf.d/sitebuilder.cnf), and this vhost normally does not have any open_basedir restrictions set ...

    The best to test is to put a info.php file into /usr/local/sitebuilder/ (with content: <? phpinfo() ?>) and check values of open_basedir ...

    There seems to also be a bug in some php versions, where open_basedir values misteriously flow into other vhosts. This problem could be decreased if one adds "php_admin_value open_basedir none" to vhost of Sitebuilder ... and then restart apache.

    Regards,

    Pink
     
  3. eddie69

    eddie69 Guest

    0
     
  4. eddie69

    eddie69 Guest

    0
     
  5. Mr. Pink

    Mr. Pink Guest

    0
     
    Hmm ..

    looks to me like buggy PHP (4.3.4!). I have seen this error with the same PHP version and SuSE Linux before.

    Sometimes it works, sometimes I get source file as download.

    I would recommend to upgrade PHP.

    Regards,

    Pink
     
  6. eddie69

    eddie69 Guest

    0
     
    Thanks again!

    I'm gonna try to see if my reseller is up for the upgrade!
     
  7. eddie69

    eddie69 Guest

    0
     
    Mr. Pink

    Do you think that might fix my problem, cause my reseller charges my to do the upgrade, just wanna make sure we are going into the right direction! no pressure....
    Thanks
     
  8. eddie69

    eddie69 Guest

    0
     
    Hi,

    The upgrade looks like fix the problem, I am still testing it but I haven't had the need to refresh the browser yet.
    Now we have some other issues with Modernbill after the upgrade but I guess that normal when you upgrade something else will fail!
    Thanks for all your help, we are very pleased with your input.
     
  9. Mr. Pink

    Mr. Pink Guest

    0
     
    You're welcome ...

    Regards,

    Pink
     
  10. tomcom

    tomcom Guest

    0
     
    I had the same problem.
    My solve:
    1.)create file named "vhost.conf" at <domainname>/conf
    2.) Write in this file:

    <Directory /home/httpd/vhosts/domain.com/httpdocs>
    php_admin_value safe_mode 0
    php_admin_value open_basedir "/home/httpd/vhosts/domain.com/httpdocs/:/"
    </Directory>

    3.) run the following command:
    /usr/local/psa/admin/bin/websrvmng -a -v

    4.) Restart apache

    You need to do that for every Website!
    Now there is no open_basedir -error.
     
  11. mdwebhosting

    mdwebhosting Guest

    0
     
    Open base prevents scripts from running outside of your main domain name. It usually happens when you access your site using the shared URL.

    WHM/cPanel has a feature in security settings to disable open base restrictions per account. Tick this and your script will function.
     
Loading...