• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Watchdog send-report still not working after problem solutions

R

RobPr

Guest
Hello,

my Plesk Panel Watchdog module (the send-report executable) is still not working -- even after I repaired it according to the forum postings and knowledge base instructions.
Please help me to finally correct the send-report file. I like the Watchdog module and it would be a pity to have to replace it with a separate solution outside of (or parallel to) Plesk Panel.

---------------------------------------------------------------
PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE

Parallels Plesk Panel 10.0.1
CentOS 5 Linux


PROBLEM DESCRIPTION AND STEPS TO REPRODUCE

- After fresh installation of server and Plesk Panel 10.0.1 I encountered the known error:
"Parallels Plesk Panel constantly sends message with the error: "Class 'OptionalServices_ServicesConfiguration' not found""
(see http://kb.odin.com/en/9329 )
(see also http://forum.parallels.com/showthread.php?p=429327 )

- Then I corrected the "Class 'OptionalServices_ServicesConfiguration' not found"-error by replacing the /usr/local/psa/libexec/modules/watchdog/cp/send-report file with the updated file provided in above mentioned kb-entry and forum thread. The "Class 'OptionalServices_ServicesConfiguration' not found"-error disappeared, but a new error came up: send-report cannot be executed.

- Then I still had to correct the first line in the updated file manually with vi, replacing the false first line "#!/opt/psa/bin/sw-engine-pleskrun" in the updated file with "#!/usr/local/psa/bin/sw-engine-pleskrun". This step was also described in the above mentioned forum thread further below. Now the error, that send-report cannot be executed, disappeared.

- But now a new error came up:

$ ./send-report daily
Failed to send message: `mail() failed: Failed to connect to 127.0.0.1:25 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]'.

Note that this error comes up in the command line as well is sent (!) to me by e-mail via the Cron Deamon.


ACTUAL RESULT

$ ./send-report daily
Failed to send message: `mail() failed: Failed to connect to 127.0.0.1:25 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]'.

Error comes up in the command line as well is sent to me by e-mail (daily) via the Cron Deamon.


EXPECTED RESULT

send-report should send the Watchdog module reports to me, instead of producing an error and failing.


ANY ADDITIONAL INFORMATION

Aside of this Watchdog send-report problem, everything else seems to be working properly.


--------------------------------------------------------------

Thank you!
 
Did you check that connection to port 25 is acceptable from localhost 127.0.0.1 ?
 
Back
Top