1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Web Preview for Resellers no working?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by JeffWebbUK1, Apr 29, 2012.

  1. JeffWebbUK1

    JeffWebbUK1 Guest

    0
     
    Hi there,

    I've recently set up a handful of reseller accounts for folk on my server, these are working fine but they have asked how they can preview websites they are moving across PRIOR to switching across DNS - the dedicated IP for the server is set to shared, and I have (on my super user login) enabled web preview - but I cannot find a setting for resellers to enable web preview, nor do I actually know what IP etc they could give to their customers to 'test' a live site before moving it.

    Because of the nature of the sites, putting them on the back of another site is not a solution, really it needs to be something like:
    "Oh, go to http://123.123.123.123/yourdomain.com/ and you can see your site before we move it across"
    I've read on the net this can be done using Plesk - but it doesn't work - and the 'preview in web browser' buttons all point to the fully qualified domain rather than an IP local URL.

    Any help or assistance would be greatly appreciated! I have complete access to the server, so anything that needs switching on/modifying is not a problem.

    Thanks in advance!
    Jeff
     
  2. swopedesign

    swopedesign Regular Pleskian

    25
    57%
    Joined:
    Nov 12, 2006
    Messages:
    106
    Likes Received:
    0
    Documentation is incorrect

    I am likewise trying to accomplish this. Plesk documentation says that after enabling Quick Preview, sites can be previewed at the following patterned URL:

    "customer-site.tld.192-0-2-12.your-domain.tld. Here 192-0-2-12 is the site's IP where dots are replaced with dashes."

    i.e.

    familyhomeeveningideas.com.67.222.1.151.fasterthanlighthosting.com

    which is awkward to say the least, and also does not work.

    I have also seen it reported on the Internet that familyhomeeveningideas.fasterthanlighthosting.com should work, but does not. I have also tried familyhomeeveningideas.com.fasterthanlighthosting.com, which also fails.

    So what's the secret? Anyone know? Documentation needs to be crystal clear in these cases, and it seems it should be a simple matter to dumb-it-down to English, instead of the documented gibberish domain.

    If I find something, I'll let you know.
     
  3. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    You don't really need to learn a pattern of producing name for site preview. Once preview feature is configured on your server (which actually means you have chosen a zone to run temporary names), you only need to click "preview" icon right to a name of a site in "Websites and Domains" tab. Until enabled, the same icon leads to a legacy preview feature, which worked differently.

    So did you configure Preview feature?
     
  4. swopedesign

    swopedesign Regular Pleskian

    25
    57%
    Joined:
    Nov 12, 2006
    Messages:
    106
    Likes Received:
    0
    Yes, it is configured. The idea is for customers to preview web sites in an environment where scripts run before the DNS is switched to the server; customers can show the site then to others without giving them control panel access.
     
  5. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    So, when you open site preview in CP, which URL is formed for the site?

    Customers can simply share the URL with others. It can be accessed outside the panel and the URL will not be changed until customer's site / its IP / preview zone are changed on your server.
     
  6. JeffWebbUK1

    JeffWebbUK1 Guest

    0
     
    Site unavailable

    Thanks for the messages - yes, preview has been enabled but when you click on the 'preview your website in a browser' button in order to get the URL, you get a 'webpage not available message'. The URL it wants seems sensible ie:

    MYIPADDRESS:8443/sitepreview/http/customerwebsite.com/?randomHash=67fc0d4991f7e68cc9546ea440d3320a

    But it doesn't work. Any further ideas please?

    Cheers,
    Jeff
     
  7. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    That means your server hasn't enabled new site preview. I think you kept "LImited Preview" selected in "Tools & Settings" > "Website Preview Settings". If you configure it properly and choose the zone to host previews, you will get the desired result.

    Regards
     
  8. JeffWebbUK1

    JeffWebbUK1 Guest

    0
     
    doesn't on reseller account though

    thanks again for the response - it is most definitely enabled and NOT on limited preview on my superuser account - it works fine on the domains I am hosting myself, unfortunately as I said at the beginning of the thread it is the reseller accounts who don't even have the web preview setting in tools/utilities. So yeah, basically it's resellers who can't use this web preview mode and I don't know why.

    Again, assistance muchly appreciated! :)
     
  9. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Okay, I see now. Sorry for missing the point.
    I've just tried it for resellers on my own server (10.4.4) - sites of reseller and sites of customer of reseller have appropriate preview URL like http://customer-of-reseller.com.10-58-239-91.******.com/
    It doesn't support branding though - all resellers will have *****.com the same as a server owner.

    There must be a reason for your server substituting wrong URL for resellers and keeping correct URL for your own site, but unfortunately I cannot assist with it remotely.
     
  10. JeffWebbUK1

    JeffWebbUK1 Guest

    0
     
    Another thing

    Well I swapped things around a bit so that now the reseller's "preview in web browser" button does indeed point you to:

    http://customer-of-reseller.com.78-129-146-44.MYMAINDOMAIN.com

    Which is absolutely fantastic... if it worked... the browser now just says it can't find this site/domain. At least it now looks the same as what you said. Is there anything else that needs adding to get this working correctly?

    Thanks again for any help.
     
  11. MiniBlueDragon

    MiniBlueDragon Guest

    0
     
    I had exactly this issue and have spent all day trying to figure it out without success.

    In the end I registered a dirt cheap domain name, set an A record to my server IP for it and then on the Plesk panel set up a domain alias from the registered domain to the installed one. Nasty workaround as the site I'm developing is technically "live" during setup but it'll do as time is of the essence.

    Good luck with sorting out the issue. :)
     
  12. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    2 JeffWebbUK1

    I think you need to add a wildcard record into your mymaindomain.com zone if it is hosted somewhere else. here is a recommendation from our inline help
    If you use this option, add the following DNS record (type A) to the external domain zone: *.<Panel_IP>.external.dom. Here <Panel_IP> is the Panel server IP where dots (.) for IPv4 or colons :)) for IPv6 are replaced with dashes (-). Say, *.192-0-2-12.external.dom. If Panel has more than one registered IP, add a record for each address.


    If it is hosted at the same instance of Plesk where you use preview feature, the zone should be configured automatically.
     
Loading...