1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

webinterface redirection issue after upgrade to plesk panel 10

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by Tobias Anselm, Dec 1, 2010.

  1. Tobias Anselm

    Tobias Anselm Guest

    0
     
    Hi,

    when I try to connect to https://myhost.mydomain.tld:8443/ index.php redirects me to https://myhost/relay:8443.
    After that it goes back to https://myhost.mydomain.tld:8443/ and I can login.
    Since myhost isn't a fqdn our customers are unable to use the panel.

    I checked the hostname in the admin panel. It has the correct value of myhost.mydomain.tld.
    I don't now where to change that redirection behavior. I tried to edit index.php manually, but had no chance. It seemed that there's just binary code in the php-files.
    I also didn't find any hint in the kb.
    The panel runs under windows server 2008 (64-bit).

    Help would be appreciated. :)
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
  3. DanielB1234

    DanielB1234 New Pleskian

    16
    60%
    Joined:
    Nov 10, 2010
    Messages:
    22
    Likes Received:
    0
    https://hostXXX.YYYhost.com:8443/relay

    Hi Igor ,

    I'm still having this problem of redirection
    I've configured the sso -s -server and url that's is correct https://hostxxx.yyyhost.com:8443

    I've made all suggestion you gave in this post ( kb 9296) host update .php ...

    The host name on the server is the realname of the machine ( hostxxx) the DNS suffix is the real domain name ( YYYhost.com) , account are in sync ...the SSL Cert. is the default one, is a new installation from scratch !!

    And the problem is still there, I'm really thinking to quit, white flag !!!

    Thank you for all your support, but let me say that this release cannot be either a release candidate ...

    Any other idea....? SSL ? ( just latest chance !!)

    Thanks
    Daniel

    OS : W2k3
     
  4. Tobias Anselm

    Tobias Anselm Guest

    0
     
    Hi Igor,

    thanks for the quick reply. I found that article before and did the recommended tasks, but that didn't fix the problem.
    So I ran the web installer and updated to 10.01 or 10.1 (I don't know the exact version number).
    That also didn't fix the problem.
    In the installer I found another component "Parallels Small Business Panel" I could add. I tought it could have something to do with it and started the installation. And that turned things into a nightmare.
    The installer said at the end something like: "contact technical support"
    I tried a repair setup at "add /remove Programs" but the plesk panel was missing. After some time I found the setup-directory where msi installer files are. tried a repair setup from there... no chance. I ask myself why parallels has removed it from "add/remove programs". The plesk-installer doesn't offer this option.
    After trying some other things I gave up and rolled the whole server back. Which took hours.
    At this time personally i wouldn't suggest to upgrade plesk. Maybe it's an better idea to migrate the data to a clean installation. Plesk 10 seems to be a very fragile application to me. I could be that the problems occurred because I installed it on Server 2008 (not R2) and that isn't approved by parallels. The question then is, Why is it possible to start the setup?
    I hope my experience
     
Loading...