1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Website issues - possibly DNS

Discussion in 'Plesk for Linux - 8.x and Older' started by rcallbeck, Aug 29, 2005.

  1. rcallbeck

    rcallbeck Guest

    0
     
    Good day,

    I am migrating my company's website to a local server.. currently in the midst of it. I thought I had everything worked out... obviously not.

    When I am on the server, I can browse to the site no problem. That is, I changed the hosts file to point to itself for the site.

    (BTW, the page is http://www.kare.ca, residing at http://142.179.163.160).

    However, on any other computer, I try to browse to either the IP address or DNS name, and I get the "hosting for this domain is not configured" page. I had our name registrar change over the ip addresses today, so it is currently in the midst of propagating.

    I have checked throughout the Plesk forums, and I can find not a whiff of this problem. My DNS entries all seem to be ok. If I go through the preview site page, it previews no problem.

    Any thoughts or ideas?

    Thanks..

    rcallbeck
     
  2. eWebtricity

    eWebtricity Guest

    0
     
    You might try restarting Apache, I have found that sometimes changes don't always take effect just by adding the domain/client to the admin panel.

    DNS lookups from the USA seem to match the domain name and IP you specified in your post. So it's not a DNS problem and since Plesk is giving a default page it means that the server is configured with the correct IP address, it's just not pointing to the proper vhost directory.

    Try restarting the Apache service.
     
  3. rcallbeck

    rcallbeck Guest

    0
     
    tried that..

    restarting apache, that is... as well as bind... to no avail.

    I have been going like crazy trying to find what might be going on... I haven't been able to find the vhosts.conf file... where should that file default to? would it be in:

    /home/httpd/vhosts/<domainname>/conf/

    or somewhere else. I am guessing it has to be that... as it keeps going to the default page...
     
  4. eWebtricity

    eWebtricity Guest

    0
     
    You should have the following in the /conf directory for each site

     
  5. rcallbeck

    rcallbeck Guest

    0
     
    That must be it... in my <domain>/conf folder, I have..

    httpd.include,
    httpd.include.bak, and
    webalizer.conf

    do you know how I could get the vhosts_ssl file re-created?

    edit: **I should note that I am connecting to the server via SSH term... but I am logged in as root
     
  6. rcallbeck

    rcallbeck Guest

    0
     
    fixed

    Thanks for all of your help... I got it fixed. Turns out there were a number of includes/references in the httpd.include that were pointing to the default folder, and not the domain. Once this was corrected, no problem... :)
     
Loading...