• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue What caused this error?

Mischa

New Pleskian
Hi,

Suddenly this error showed up:

ERROR: PleskDBException: Unable to connect to database: mysql_connect(): Connection refused /var/lib/mysql/mysql.sock (Error code: 2002). Please check that database server is started and accessible. (Abstract.php:69)

Since nothing changed on the server i wonder which trigger caused this error. Knowing this maybe can prevent that this will happen on my new server.

Because we couldn't fix it we added a new server with a fresh install. So every feedback can help us prevent the same error occurs.

Thanks!
 
What is
# service mariadb status
saying?

Have you tried
# service mariadb restart
?
 
To find the reason why the database server crashed you will need to look at the systemmessages log and the database server's log file at the time when the database crashed.
 
Back
Top