1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

What do I need to do to install Plesk on SuSe 9.1 Linux?

Discussion in 'Plesk for Linux - 8.x and Older' started by Banaticus, Dec 16, 2004.

  1. Banaticus

    Banaticus Guest

    0
     
    http://www.sw-soft.com/en/download/plesk75reloaded/ states "Use of the Plesk RPM software requires a reasonable level of experience with RPM based installations. We recommend that you use the Plesk 7.5 Reloaded Auto-installer for clean installations and upgrades."

    So, I try to download the auto installer. I saved it in my root folder. I opened my Personal Files folder, moved over to it, and clicked on it. Nothing happened. I tried opening it, thinking that it might run itself. No, I just got a lot of gobbledy-gook text.

    So, I tried running the installation myself. I saved the file, unpacked it, then tried to run the "rpm -Uvh *.rpm" commands on the various directories in the rpm_SuSE_9.1 folder. It turns out that I don't have the prerequisite rpms installed. Namely, I need all of the rpms listed in this document, file:/rpm_SuSE_9.1/psa-7.5.1-suse9.1.build75041216.14.i586.txt

    I've checked over my SuSE 9.1 CDs umpteen times, tried searching the Suse site (which means wading through all of the Novell junk relating to other programs that I'm not interested in), and I can't find these files anywhere.

    Question 1 of 2:
    What should a completely n00bish neophyte to Linux do to get Plesk installed and running?

    Question 2 of 2:
    What's the command to run the rpm command on all files in a directory and the directory's subdirectories? There's the base folder, and then 14 subdirectories in the opt folder. I'd rather not have to type in "rpm -Uvh *.rpm" in all of those folders.

    P.S. This window that you have to write your messages in is incredibly thin compared to every other bulletin board that I've ever been to.

    Edit: I tried the 30 day email support, but it told me that my key number is invalid when I tried to fill out the form. I printed out my key number that I was emailed and, yup, I'm typing in the number that I was given. Phone support told me to go check out the SuSE website, that Plesk can't be bothered to provide the necessary files to make it work (not their exact words, but that's my feeling).
     
  2. hardweb

    hardweb Guest

    0
     
    1. You can do this with the autoinstaller. Execute the commands:

    wget http://download1.sw-soft.com/Plesk/Plesk7.5/Suse9.1/psa_
    installer_v2.0.0_build75041129.17_os_SuSE_9.1_i686
    --00:05:29-- http://download1.sw-soft.com/Plesk/Plesk7.5/Suse9.1/psa_installer_
    v2.0.0_build75041129.17_os_SuSE_9.1_i686

    chmod 700 psa_installer_v2.0.0_build75041129.17_os_SuSE_9.1_i686

    ./psa_installer_v2.0.0_build75041129.17_os_SuSE_9.1_i686

    and it will start.

    2. You must change to the base directory and execute:

    rpm -Uvh *.rpm
     
  3. Banaticus

    Banaticus Guest

    0
     
    It tells me, "Warning! The newer versions of packages required for installation were found in the system..." At the end of the install it says:
    Installing postgresql-7.4.6-0.2.i586.rpm
    Installing postgresql-server-7.4.6-0.2.i586.rpm
    error: Failed dependencies:
    postgresql-libs = 7.4.6 is needed by postgresql-7.4.6-0.2

    How should I get this file that I need? I've tried the YaST Online Update, but it doesn't see the file that I need.

    Thanks for your help so far.
     
  4. hardweb

    hardweb Guest

    0
     
    If you do not have a postgresql Plesk license, you can opt to not install postgresql at all.
     
  5. Banaticus

    Banaticus Guest

    0
     
    [edit]By the way, thanks a lot for your help.[/edit]

    During the install, it asks me, "Warning! The newer versions of packages required for installation were found in the system. You can resume setup, however there might be problems with dependencies.
    Proceed anyway? (y/n):"

    If I choose no, the install ends. If I choose yes, then the install just whizzes along until it gets to the point where it says, "error: Failed dependencies: postgresql-libs = 7.4.6 is needed by postgresql-7.4.6-0.2".

    It then says, "Not all required packages were installed. Press <ENTER> to continue..." After I press Enter, the install goes back to the very beginning.

    During the install, my only choice of a Plesk release is Plesk 7.5.2. How do I choose not to install postgresql, but to install everything else?

    I'm sorry, I'm not very good with Linux.
     
  6. hardweb

    hardweb Guest

    0
     
    Execute the command:

    rpm -qa | grep "postgresql" | xargs rpm -e

    Then try again the installer.
     
Loading...