1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Where is the command line interface? Please help

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Tiffany Jonas, Aug 27, 2010.

  1. Tiffany Jonas

    Tiffany Jonas Guest

    0
     
    I have a virtual private server with GoDaddy that uses the Parallels Plesk 9.3 panel. I am trying to increase the maximum number of entries in one person's whitelist, and I have found the command to do this, but I cannot access the command prompt/command line interface anywhere.

    I have Googled this topic for two hours, contacted GoDaddy, and searched this forum but have been unable to locate the answer. All I see are things like "Log into the root and type in this command", but when I log into Plesk, there is nowhere for me to type in a command; there are just icons to click on, and none of them say anything about a command line interface. As you can probably tell from my post, I am no network administrator, so please bear with me.

    Can someone please help me locate the command line interface so I can enter the necessary command? Thank you SO much.
     
  2. Tiffany Jonas

    Tiffany Jonas Guest

    0
     
    No one knows where this is?

    Is there anyone who can help me?
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Login as root via ssh connection and run your command in console.
     
  4. Tiffany Jonas

    Tiffany Jonas Guest

    0
     
    Thank you for responding to my plea for help!

    Can you tell me how I would carry out your instructions? Here's what I see:

    - I go to the online Plesk login page ("Log in to Parallels Plesk Panel 9.3")

    - I don't see any options except the login fields/button and a link to the Parallels website; there is no option to engage an SSH connection

    - I log in as admin (I tried logging in as "root" instead of "admin" but I don't know the password for that, and it wouldn't take my admin password)

    - I see many icons, none of which are labeled "console"

    Can you please explain what to do in very simple layman's terms?

    Again, thank you for your help!!
     
  5. Tiffany Jonas

    Tiffany Jonas Guest

    0
     
    No one knows how to do this? Can anyone help me?
     
  6. 64bithost.com

    64bithost.com Regular Pleskian

    25
    57%
    Joined:
    Jul 30, 2007
    Messages:
    182
    Likes Received:
    0
    Command line interface in PLESK

    Hi Tiffany,

    to locate the Command line interface in PLESK do the following.

    1. goto you plesk panel and login using your login and password
    2. click on domains on the left hand panel
    3. click on your domain
    4. under "files" locate ssh panel

    5. if it is not there do the following

    6. click on "domain administrator access"
    7. slide down to "Management of access to server over SSH"
    8. choose "Domain administrator can allow access to any type of shell"
    9. save your work
    10. repeat steps 3 and 4
     
  7. Tiffany Jonas

    Tiffany Jonas Guest

    0
     
    Glorious!!! You are wonderful! I had to take an extra step but you supplied the information that I needed to get there.

    For anyone else who is trying to find the command prompt in Plesk on a virtual server, follow the steps given by 64bithost.com:

    Hi Tiffany,

    to locate the Command line interface in PLESK do the following.

    1. goto you plesk panel and login using your login and password
    2. click on domains on the left hand panel
    3. click on your domain
    4. under "files" locate ssh panel

    5. if it is not there do the following

    6. click on "domain administrator access"
    7. slide down to "Management of access to server over SSH"
    8. choose "Domain administrator can allow access to any type of shell"
    9. save your work
    10. repeat steps 3 and 4

    If the SSH Terminal icon is still grayed out, while you're still in that domain, click on the "Web hosting setup" icon, look down the page until you see "Shell access to server with FTP user's credentials", and if it says, "Forbidden" next to it, change it to another type of shell. (A big than kyou to "noname1984" in another Parallels thread for this part.)

    Thank you, 64bithost.com!
     
Loading...