• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question Why "/usr/bin/mysql: unknown variable 'symbolic-links=0'" on upgrade from 12 to 12.5?

Bitpalast

Plesk addicted!
Plesk Guru
About to upgrade a Plesk 12.5.30 installation to Plesk Onyx 17.5 on CentOS 7.1. On an upgrade from Plesk 12.0 to 12.5 last year we experienced this issue:

Code:
===> Upgrading database

 Trying to start service mariadb... active

done

 Trying to establish test connection... /usr/bin/mysql: unknown variable 'symbolic-links=0'

/usr/bin/mysql: unknown variable 'symbolic-links=0'
/usr/bin/mysql: unknown variable 'symbolic-links=0'
...
/usr/bin/mysql: unknown variable 'symbolic-links=0'

Will we see this error again on the upgrade step from 12.5.30 to 17.5?

I cannot recall how the issue was solved, because the "symbolic-links=0" is set in all of our machines, so obviously the setting is o.k. to use. MariaDB is up and running. Does anyone know why the upgrade routine throws the "unknown variable 'symboli-links=0'" error? I don't want to run into the issue again once the upgrade is done. Sure it is always possible to disable the line in the configuration file, but we'd like to understand why the error existed at all. Maybe there are other implications this can have?
 
Back
Top