1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Wildcard Subdomain in plesk

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by roberthov, Mar 17, 2011.

  1. roberthov

    roberthov Guest

    0
     
    Well this is my 4th question in this forum, and hopefully it gets answered (crossing fingers)

    Configuration.
    OS Microsoft Windows 6.1;build-7601;sp1.0;suite1296;product3
    server --> WINDOWS web server 2008 R2 - sp1
    IIS 7.5
    Panel version 10.1.1


    I need help with the following.
    whenever i go to something.domain.com the page loads as if i went to domain.com itself. It DOESN"T redirect, just loads as if i'm in domain.com

    For the record
    I never did anything to the initial plesk configuration. this has been like that since i set up the server image with 1and1
    EDIT; The initial plesk setup came with 10.0.1 version i believe and it's been like that even before i updated plesk to 10.1.1

    Now i don't have a sub domain configured like something.domain.com neither in plesk nor in 1and1 admin area.

    BUT i do have a subdomain zzzz-wildcard.domain.com which points to a different directory other than the root.


    I did some searching around but all plesk related wildcard subdomian searches in google were related to linux servers where u also configure vhost.conf and be done with it..... but i'm on windows.

    THE BEST PART
    So my question is why isn't the something.domain.com being caught as a non existing subdomain and why's it's loading domain.com instead of zzzz-wildcard.domain.com

    since i already have subdomain zzzz-wildcard.domain.com. It works no problem when i go directly to it. i also have dns entry in plesk
    zzzz-wildcard.domain.com.------------A------------000.208.209.156


    I created a wildcard subdomain entry in dns

    *.domain.com.------------CNAME------------zzzz-wildcard.domain.com. ---> didn't work, still loads domain.com

    i tried
    *.domain.com.------------CNAME------------domain.com. ---> didn't work, still loads domain.com

    i tried
    *.domain.com.------------A------------000.208.209.156 ---> didn't work, still loads domain.com

    i tried restarting plesk, and the server after each configuration ---> didn't work, still loads domain.com


    help. i'm going nuts with plesk.


    Current dns entries
    *.domain.com.------------CNAME------------zzzz-wildcard.domain.com.
    000.208.209.156 / 24------------PTR------------domain.com.
    ftp.domain.com.------------CNAME------------domain.com.
    domain.com.------------NS------------ns1.domain.com.
    domain.com.------------NS------------ns2.domain.com.
    domain.com.------------A------------000.208.209.156
    domain.com.------------MX (10)------------mail.domain.com.
    lists.domain.com.------------CNAME------------domain.com.
    mail.domain.com.------------A------------000.208.209.156
    mssql.domain.com.------------A------------000.208.209.156
    mysql.domain.com.------------A------------000.208.209.156
    ns1.domain.com.------------A------------000.208.209.156
    ns2.domain.com.------------A------------000.208.209.178
    sitebuilder.domain.com.------------A------------000.208.209.156
    webmail.domain.com.------------A------------000.208.209.156
    -www.domain.com.------------CNAME------------domain.com.
    zzzz-wildcard.domain.com.------------A------------000.208.209.156
     
    Last edited by a moderator: Mar 18, 2011
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Could you please describe with step-by-step how this subdomain has been created in your Plesk?
     
  3. roberthov

    roberthov Guest

    0
     
    in the https://MYIPADDRESS:8443/smb/web/view clicked on "websites & domains" tab

    clicked on add subdomain, entered zzzz-wildcard in the text box next to the dropdown .domain.com

    ----------------------screenshots-------------------------------


    logged in --> domains --->control panel of my image
    http://img560.imageshack.us/img560/6877/goingtoctrlpnl.jpg

    in the new window went to websites and domains & added subdomain
    http://img34.imageshack.us/img34/1763/addingsubdomain.jpg

    subdomain added
    http://img195.imageshack.us/img195/134/addedsubdomain.jpg


    after adding the wildcard subdomain , it works just fine when i go directly to zzzz-wildcard.domain.com but something.domain.com just loads domain.com it doesn't redirect to domain.com just loads as if i'm in domain.com. To clarify: I don't want it to redirect, i want to catch it in the wildcard subdomain. while it's displaying something.domain.com in url.

    so i added dns entry *.domain.com cname
    http://img835.imageshack.us/img835/5720/currentdnsentries.jpg

    in regards to last one. server is in master mode.
    http://img143.imageshack.us/img143/3612/dnssettings.jpg


    i tried to *.domain.com cname domain.com
    i tried *.domain.com A ipaddress

    but they wouldn't work either
     
    Last edited by a moderator: Mar 18, 2011
  4. roberthov

    roberthov Guest

    0
     
    ------------------------UPDATE --------------------------

    i solved the problem by logging in via remote desktop and manually changing iis settings.
    Even though i'm not sure this is the right way to do it as i'd expect plesk dns entries to actually work?

    i would think plesk would handle this, but i guess not. In either case it might be helpful to someone else so they don't have to bang their head against the wall trying to figure this out.

    Removed the circled entry from domain.com's bindings
    Removed Binding Screenshot

    added new entry to zzzz-wildcard.domain.com's bindings
    Added Binding Screenshot
     
    Last edited by a moderator: Mar 18, 2011
  5. roberthov

    roberthov Guest

    0
     
    ---------One more update---------

    after a while, plesk has automatically re-added the wildcard binding for the main website (not subdomain) in IIS
    the binding that was removed manually and for some reason reappeared after a while
    This has caused the website to stop. I had to manually remove the binding again to be able to start the website again.


    Please help. Any workarounds... better solutions are much appreciated
     
Loading...