1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Write access permissions

Discussion in 'Plesk for Linux - 8.x and Older' started by Claxon, Feb 2, 2007.

  1. Claxon

    Claxon Guest

    0
     
    Hey everyone I'm wondering if anyone can give me any help with a little permissions problem i've been having.

    The basic story is this I have a website that uses php extensivly (www.mywebsite.net). While I'm developing new code I test it in a subdomain of that site (dev.mywebsite.net). One of the latest things I've made is a script that creates images and writes them to the img/map/ directory.

    When setting it up on the dev subdomain, all I did was ftp to the subdomain, upload my script, create the img/map/ directory and then chmod it to 0777 (a nice easy 2 minute job). All was well... the images were written perfectly.

    Then came time to move the changes to the primary site, so I repeted the above steps... uploaded script, created directory and chmod 0777, but this time the images are not written. The script is constantly being denied write access to any files in that directory, but I can't for the life of me, figure out why. If I look in the Plesk file manager at the directory it states the permissions as "rwx rwx rwx".

    I'm lead to thinking it's something to related to the way plesk set up the sub-domain, some difference from the actual domain, but don't know where to go looking or really what to look for.

    Any help would be much appreciated!
     
  2. ClausVB

    ClausVB Guest

    0
     
    Check your "php.ini" and OPEN_BASEDIR and SAFE_MODE:
    http://php.net/en/features.safe-mode

    If error messages are disabled and SAFE_MODE is on, this could be a problem.

    Regards,
    Claus
     
Loading...