1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Writing files with CGI/Perl

Discussion in 'Plesk for Linux - 8.x and Older' started by tutt, Jul 17, 2006.

  1. tutt

    tutt Guest

    0
     
    If I create a simple script such as:

    open (TESTWR, "> testit");
    print TESTWR "testo";
    close TESTWR;

    Perl will not create and write to this file no matter what the permissions on the directory. If I run the perl script via shell as root, it works, but otherwise, no go. I ran some other tests through perl via CGI and the web, and I was able to find out that it was not running via suexec (or at least running "whoami" showed the user "apache" - also it was interesting that the "pwd" command showed "/").

    This is a big problem for me. How can I get perl to run through CGI via suexec and have it be able to write and create files?
     
Loading...