1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Wrong document Root & Certificate Issues -

Discussion in 'Plesk for Linux - 8.x and Older' started by Chillstrike, Sep 16, 2008.

  1. Chillstrike

    Chillstrike Guest

    0
     
    Hi Everyone:

    I have the following issue since installing my server new.
    Symptom 1: When I create a domain - and try to visit the domain - plesk always redirects me to the wrong document root (Standard from plesk)
    Symptom 2: When I go in CP to Server --> IP addresses and click on my IP I always get the same this error:
    Code:
    ERROR: PleskFatalException
    Unable to create certificate: SSLCertificate: unable to select: no such row in the table
    0: /usr/local/psa/admin/htdocs/server/ip_ctrl.php:213

    As i remenber, it worked in the first place (when i had no domains configured)

    Sure i tried to solve the problem by googeling - to at least get the domains working somehow...

    Seems as some people got a similar issue so i found this tricky way here on the forum (unfortunatly it didn't work for me):
    You should fix Plesk database manually to resolve this problem.
    Get the list of all certificates exist in Plesk:

    mysql> select id from certificates;

    Configure Plesk to use an existent SSL certificate, one of psa.certificates.id:

    mysql> replace into misc values ('default_certificate_id',<ID>);

    ./anb
    Complete thread: http://forum.swsoft.com/showthread.php?t=48119

    It sound very clear to me - but as told before it didn't work.

    I also tried several other tips:
    httpd restart
    psa restart
    Server reboot
    Domain deactivate/activate

    But - nothing helped!!!

    And after 5 days of trying to solve the problem - it seems even google's index has an end.

    Here my facts:
    Plesk version: 8.6
    OS: Suse 10.3
    Hoster: 1und1
    Typ: Root Server
    Shared IP
    apporx. 10 Domains

    I switched of SSL for every domain and also diabled DNS (from Server --> DNS)
    I have one certificate (self-signed) - don't need ssl for the domains anyway - but it doesn't work even when i delete the certificate

    Other things i found that might help:
    As told i have 1 certificate - but in the database it says (solution from above) that i have 2 certificates (ID 2+7).
    I also added certificates for each domain but that didn't change a bit...

    Please please help me (thinking)..

    If you like i can provide you with log files i.e.

    Thank you!

    Cheers

    Chillstrike
     
Loading...