1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

yum help

Discussion in 'Plesk for Linux - 8.x and Older' started by zboyblue, Jan 16, 2005.

  1. zboyblue

    zboyblue Guest

    0
     
    I am continuing to work on a new server that I loaded FC2 and Plesk 7.5.1 onto. I am trying to go through all sorts of tests now to make sure I have covered all the bases so that when I am ready to load my production server I will have already worked all the bugs out and know what I plan to do before I do it.

    I have never used yum but decided I should probably do a test run with it to try and learn how it works, etc. I am not sure if it is supposed to be this way or not but yum was alreadu installed on my system. I typed yum check-update to get the list of headers which it did. I then typed yum update and got the following. My question is, should this be what I saw and what I updated? I am not sure if there are some things I shouldn't update and some I should or what so any imput is appreciated.

    I will do the following:
    [install: kernel 2.6.10-1.9_FC2.i686]
    [update: system-config-users 1.2.28-0.fc2.1.noarch]
    [update: pango 1.4.1-1.i386]
    [update: cups 1:1.1.20-11.9.i386]
    [update: samba-client 3.0.10-1.fc2.i386]
    [update: postgresql-libs 7.4.6-1.FC2.2.i386]
    [update: xorg-x11-xauth 6.7.0-11.i386]
    [update: php-pgsql 4.3.10-2.4.i386]
    [update: rpm 4.3.1-0.4.1.i386]
    [update: pcmcia-cs 3.2.7-1.8.2.2.i386]
    [update: gdk-pixbuf 1:0.22.0-11.3.5.i386]
    [update: ORBit2 2.10.0-4.i386]
    [update: samba-common 3.0.10-1.fc2.i386]
    [update: xorg-x11-tools 6.7.0-11.i386]
    [update: initscripts 7.55.2-1.i386]
    [update: system-config-network-tui 1.3.17-0.FC2.1.noarch]
    [update: php 4.3.10-2.4.i386]
    [update: finger 0.17-24.i386]
    [update: net-tools 1.60-25.1.i386]
    [update: cdda2wav 8:2.01.1-0.FC2.1.i386]
    [update: ethereal 0.10.5-0.2.2.i386]
    [update: vim-enhanced 1:6.3.054-0.fc2.1.i386]
    [update: cups-libs 1:1.1.20-11.9.i386]
    [update: vim-minimal 1:6.3.054-0.fc2.1.i386]
    [update: libuser 0.52.5-0.FC2.1.i386]
    [update: system-config-network 1.3.17-0.FC2.1.noarch]
    [update: cdrecord 8:2.01.1-0.FC2.1.i386]
    [update: apr-util 0.9.4-14.2.i386]
    [update: libwnck 2.6.0.1-3.i386]
    [update: ppp 2.4.2-5.2.FC2.i386]
    [update: imlib 1:1.9.13-19.i386]
    [update: GConf2 2.6.0-7.i386]
    [update: glibc 2.3.3-27.1.i686]
    [update: xorg-x11 6.7.0-11.i386]
    [update: zip 2.3-26.2.i386]
    [update: hwdata 0.120-1.noarch]
    [update: xorg-x11-xfs 6.7.0-11.i386]
    [update: gstreamer 0.8.3-2.i386]
    [update: kudzu 1.1.68.2-1.i386]
    [update: gtk2 2.4.14-1.fc2.i386]
    [update: libxml2 2.6.16-2.i386]
    [update: gd 2.0.21-5.20.1.i386]
    [update: system-config-samba 1.2.22-0.fc2.1.noarch]
    [update: lha 1.14i-14.1.i386]
    [update: vim-common 1:6.3.054-0.fc2.1.i386]
    [update: glib2 2.4.8-1.fc2.i386]
    [update: fam 2.6.10-9.FC2.i386]
    [update: xorg-x11-100dpi-fonts 6.7.0-11.i386]
    [update: sox 12.17.4-4.fc2.i386]
    [update: vnc-server 4.0-5.i386]
    [update: kdelibs 6:3.2.2-10.FC2.i386]
    [update: xorg-x11-libs 6.7.0-11.i386]
    [update: libtiff 3.5.7-22.fc2.i386]
    [update: cyrus-sasl 2.1.18-2.2.i386]
    [update: system-config-kickstart 2.5.19-1.fc2.noarch]
    [update: php-mysql 4.3.10-2.4.i386]
    [update: mozilla-nspr 37:1.7.3-0.2.0.i386]
    [update: cyrus-sasl-md5 2.1.18-2.2.i386]
    [update: nscd 2.3.3-27.1.i386]
    [update: gaim 1:1.1.0-0.FC2.i386]
    [update: popt 1.9.1-0.4.1.i386]
    [update: libgnome 2.6.0-3.i386]
    [update: xorg-x11-75dpi-fonts 6.7.0-11.i386]
    [update: redhat-artwork 0.96-2.i386]
    [update: xorg-x11-base-fonts 6.7.0-11.i386]
    [update: samba 3.0.10-1.fc2.i386]
    [update: mozilla-nss 37:1.7.3-0.2.0.i386]
    [update: system-config-date 1.7.3.1-0.fc2.1.noarch]
    [update: libxml2-python 2.6.16-2.i386]
    [update: xorg-x11-xdm 6.7.0-11.i386]
    [update: mozilla 37:1.7.3-0.2.0.i386]
    [update: mysql-server 3.23.58-9.1.i386]
    [update: ftp 0.17-21.i386]
    [update: glibc-common 2.3.3-27.1.i386]
    [update: cyrus-sasl-plain 2.1.18-2.2.i386]
    [update: tcpdump 14:3.8.2-6.FC2.1.i386]
    [update: mailman 3:2.1.5-7.i386]
    [update: libxslt 1.1.12-2.i386]
    [update: info 4.7-4.i386]
    [update: xinitrc 3.42-1.noarch]
    [update: tzdata 2004e-1.fc2.noarch]
    [update: xorg-x11-twm 6.7.0-11.i386]
    [update: mysql 3.23.58-9.1.i386]
    [update: foomatic 3.0.1-3.1.i386]
    [update: php-pear 4.3.10-2.4.i386]
    [update: qt 1:3.3.3-0.1.i386]
    [update: xorg-x11-font-utils 6.7.0-11.i386]
    [update: dvd+rw-tools 5.21.4.10.8-1.FC2.1.i386]
    [update: libbonobo 2.6.2-1.i386]
    [update: httpd 2.0.51-2.9.i386]
    [update: kdebase 6:3.2.2-8.FC2.i386]
    [update: rpm-python 4.3.1-0.4.1.i386]
    [update: wget 1.9.1-16.fc2.i386]
    [update: dhclient 2:3.0.1rc14-1.i386]
    [update: nfs-utils 1.0.6-22.i386]
    [update: krb5-libs 1.3.6-1.i386]
    [update: kdegraphics 7:3.2.2-1.1.i386]
    [update: libpng 2:1.2.8-1.fc2.i386]
    [update: xorg-x11-Mesa-libGL 6.7.0-11.i386]
    [update: xorg-x11-Mesa-libGLU 6.7.0-11.i386]
    [update: mod_ssl 1:2.0.51-2.9.i386]
    [update: libpcap 14:0.8.3-6.FC2.1.i386]
    [update: system-config-display 1.0.17-2.noarch]
    [update: gstreamer-plugins 0.8.2-2.1.i386]
    [update: shadow-utils 2:4.0.3-55.i386]
    [update: slang 1.4.9-12.i386]
    [update: mkisofs 8:2.01.1-0.FC2.1.i386]
    [update: rsync 2.6.2-1.fc2.0.i386]
    [update: php-imap 4.3.10-2.4.i386]
    [update: xorg-x11-libs-data 6.7.0-11.i386]
    [update: man 1.5o1-6.i386]
    I will install/upgrade these to satisfy the dependencies:
    [deps: php-mbstring 4.3.10-2.4.i386]
    [deps: libgpg-error 0.7-1.i386]
    [deps: libgcrypt 1.2.0-1.i386]
    Is this ok [y/N]: y

    Is installing all this ok [y/N]: :)
     
  2. wizbones

    wizbones Guest

    0
     
    I have installed all FC2 updates with only one issue - one of them broke horde so it displayed in aribic, but there is a fix in the forums for that. Other than that, I've had no trouble running all the yum updates to date.
     
  3. zboyblue

    zboyblue Guest

    0
     
    Thanks for your reply. How did you know it broke Horde? I mean what was the tell? I ran all updates and everything seems fine but the server is not live so there may be things I have not checked.

    Craig
     
  4. wizbones

    wizbones Guest

    0
     
    By going to http://webmail.domain.com it was in english before I updated and afterwards was in aribic across all domains.

    After fixing all was back to normal. Just had to replace an ioncube file if memory serves me correctly.
     
  5. zboyblue

    zboyblue Guest

    0
     
    I just checked my webmail and it is in Arabic! LOL

    Can you remmeber what you had to do or what thread contained the answer?

    Craig
     
  6. wizbones

    wizbones Guest

    0
     
  7. Redah

    Redah Guest

    0
     
    Just as a side note... did you do a 'minimal' install of FC2?

    Because I see stuff like DVDRW tools and CDDA2WAV etc... not really useful on a server unless you're planning to burn dvd's or something.

    If they're there because you want them to, leave them, but if not... well, I like my systems as 'light' as possible :)
     
  8. zboyblue

    zboyblue Guest

    0
     
    Ok I went to that thread but I couldn't understand what I am supposed to do. What is ioncube? Why would it (or wouldn't it) be enabled in PHP. I would love to understand the problem before fixing it, I like to know what caused the prblem so I can avoid it in the future. : )

    Let me know your thoughts.

    Also, I do have some other stuff installed on this machine because my project was to learn more about linux, learn the new Plesk (since I have 6 now), implement all the new 4PSA tools, make sure nothing goes wrong and just kinda do a "test run" before installing and configing for real. As usual when I start playing with linux again I got the "I want to use this as my desktop" fever so I installed a good bit at install time so I could play with it and try it out. Not sure if I could actually work off of linux all day or not but I think it could be cool if I could. No more Microsoft! : )

    Craig
     
  9. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    ioncube is a 3rd party extention for php. If you didnt install it in the first place I dont think this issue applies to you. Ioncube is closed source binary only stuff.


    I kind of go back and forth on what I install on an OS, before yum and red-carpet I always would do an everything install, since Im always modifying or building things. These days with yum, I generally go with a minimal and then yum up whatever Im missing, then again Ive been running linux for over 11 years now so I know what everything does, and where it goes. My advice to anyone planning on doing development on some of the complex packages (php notably) is to go with an everything install, and avoid the dependency resolution whack-a-mole that a minimal (or even development!) install will leave you with.

    Side note, I run FC3 for my desktops, and Ive lately been deploying it on my non-technical family members systems with considerable success. Id say if youre largely using your system for IM, email, web or office/graphics you're going to be pleasently surprised. For the folks using a lot of wierd apps Id say it would be a frustrating experience (but at least there wouldnt be any malware).
     
  10. zboyblue

    zboyblue Guest

    0
     
    I too was thinking about the possibilities of Linux for family. The thought of being able to build a somewhat cheap machine and load a free IOS makes me want to give less than able family members a computer for internet access. Or even less fortunate families! That is even better! Wow, that could be cool depending on how cheap you could get the PC's.

    About ioncube, I went to the directory where the other thread said it was located and it was there. What does that mean? Did I install something by mistake when installing to begin with? What was it called and should I not install it next time? Did installing that newly downloaded version fix the "problem" or was it a matter of selecting the language the whole time? I appreciate your input on this; I would like to know what caused this and how to avoid it in the future.

    About FC3, is there any major difference in the way it looks or feels or the packages? I have not read up on it but I assumed it was just a new core.

    Thanks for all your help in these forums!

    Craig
     
  11. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    If you're looking for a liveCD distro just to show to some people Id check out Knoppix, www.knoppix.org. Also fantastic for rescue work on linux, windows, *bsd*, etc.

    Whats impressed me on FC3 for desktop use has been the cleanup on the more subtle things, like hotplugging devices (cameras, mobile phones, firewire, etc), wireless support (automatic network detection, roaming profiles), and the file manager, nautilus, for burning DVD's and CD's.

    They also adopted a desktop more like Ximians (im speaking of gnome here, not KDE), which Ive always preferred.
     
  12. zboyblue

    zboyblue Guest

    0
     
    What is this about? I am confused.

    "If you're looking for a liveCD distro just to show to some people Id check out Knoppix, www.knoppix.org. Also fantastic for rescue work on linux, windows, *bsd*, etc."
     
  13. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Did ya try looking at the website? :p LiveCD's == an OS that lives on the CD, not on the harddrive. Generally used for demonstration, or rescue.
     
  14. zboyblue

    zboyblue Guest

    0
     
    I appreciate the link but what I am confused about is why you gave it? Is it supposed to be a solution to one of my problems or is it just something cool? Sorry if I am totally missing what you are trying to tell me. : (

    Also, what about the question I asked about ioncube, do you know?

    Thanks!

    Craig
     
Loading...