• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Question yum update conflict

Erwan

Regular Pleskian
Server operating system version
AlmaLinux 9.4
Plesk version and microupdate number
18.0.63
Hi all,

We have servers with Plesk / Almalinux 9.

When we try to do a yum update, we get the following message:

# yum update
Last metadata expiration check: 2:51:22 ago on Mon Sep 9 06:01:22 2024.
Error:
Problem 1: package iptables-legacy-1.8.10-2.2.el9.x86_64 from @System requires (iptables-libs(x86-64) = 1.8.10-2.el9 or iptables-libs(x86-64) = 1.8.10-2.el9_1), but none of the providers can be installed
- cannot install both iptables-libs-1.8.10-4.el9_4.x86_64 from baseos and iptables-libs-1.8.10-2.el9.x86_64 from @System
- cannot install both iptables-libs-1.8.10-4.el9_4.x86_64 from baseos and iptables-libs-1.8.10-2.el9.x86_64 from baseos
- cannot install the best update candidate for package iptables-libs-1.8.10-2.el9.x86_64
- cannot install the best update candidate for package iptables-legacy-1.8.10-2.2.el9.x86_64
Problem 2: problem with installed package iptables-legacy-1.8.10-2.2.el9.x86_64
- package iptables-legacy-1.8.10-2.2.el9.x86_64 from @System requires (iptables-libs(x86-64) = 1.8.10-2.el9 or iptables-libs(x86-64) = 1.8.10-2.el9_1), but none of the providers can be installed
- package iptables-legacy-1.8.10-2.2.el9.x86_64 from epel requires (iptables-libs(x86-64) = 1.8.10-2.el9 or iptables-libs(x86-64) = 1.8.10-2.el9_1), but none of the providers can be installed
- cannot install both iptables-libs-1.8.10-4.el9_4.x86_64 from baseos and iptables-libs-1.8.10-2.el9.x86_64 from @System
- cannot install both iptables-libs-1.8.10-4.el9_4.x86_64 from baseos and iptables-libs-1.8.10-2.el9.x86_64 from baseos
- package iptables-nft-1.8.10-4.el9_4.x86_64 from baseos requires iptables-libs(x86-64) = 1.8.10-4.el9_4, but none of the providers can be installed
- cannot install the best update candidate for package iptables-nft-1.8.10-2.el9.x86_64


It seems to be an iptables-libs version conflict.
What is the best way to go about solving the problem?

# yum list installed iptables\*
Installed Packages
iptables-legacy.x86_64 1.8.10-2.2.el9 @epel
iptables-legacy-libs.x86_64 1.8.10-2.2.el9 @epel
iptables-libs.x86_64 1.8.10-2.el9 @baseos
iptables-nft.x86_64 1.8.10-2.el9 @baseos
 
Back
Top