1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

10.3.1 upgrade problems

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by jola, Aug 14, 2011.

  1. jola

    jola Basic Pleskian

    19
    60%
    Joined:
    Dec 26, 2010
    Messages:
    40
    Likes Received:
    1
    I am having problems upgrading Plesk 10.2 to 10.3.1. At first I could not get the upgrade to work. Then, I finally managed to make it run. The upgrade reported success but then when I logged in to plesk it said components needed updates. The component that needed updates was:

    "Different Apache web server versions: Apache web server support"

    When I tried to perform that update it gave me an error. I will include the error log below.

    After surfing the forums here I saw some advice to run bootstrapper.sh repair, so I did that (the latest version in /usr/local/psa/bootstrapper). That ran through fine, but it did not solve my problem to update components. I also noticed that after I ran this the title of plesk when I login is 10.3.0 and not 10.3.1, as it was before.

    I'm confused and worried. Any hint of what I can to to fix this?

    Here is a copy of the error log when I try to update components:

    Execute command rpm -qa --queryformat 'F:system_installed_%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\nN:%{NAME}\nE:%{EPOCH}\nV:%{VERSION}\nL:%{RELEASE}\nA:%{ARCH}\nf:%{INSTALLTIME}\nB:%{BUILDTIME}\n[R:%{REQUIRENAME} %{REQUIREFLAGS:depflags} %{REQUIREVERSION}\n][P:%{PROVIDENAME} %{PROVIDEFLAGS:depflags} %{PROVIDEVERSION}\n][P:%{FILENAMES}\nm:%{FILEMODES}\n5:%{FILEMD5S}%{FILELINKTOS}\n][C:%{CONFLICTNAME} %{CONFLICTFLAGS:depflags} %{CONFLICTVERSION}\n][O:%{OBSOLETENAME} %{OBSOLETEFLAGS:depflags} %{OBSOLETEVERSION}\n]X:\n' > /tmp/autoinstaller_system_packages.cache
    read cache file
    (update package names cache) Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/)/thirdparty-10.3.1-cos5-x86_64.hdr.gz
    File downloading PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/thirdparty-10.3.1-cos5-x86_64.hdr.gz: 15%..21%..32%..41%..50%..62%..74%..80%..92%..100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/thirdparty-10.3.1-cos5-x86_64.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/update-rpm-RedHat-all-all/)/update-10.3.0-rhall-all.hdr.gz
    File downloading BILLING_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz: 100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/dist-rpm-RedHat-all-all/)/build-10.3.0-rhall-all.hdr.gz
    File downloading BILLING_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/update-rpm-CentOS-5-x86_64/)/update-10.3.1-cos5-x86_64.hdr.gz
    File downloading PSA_10.3.1/update-rpm-CentOS-5-x86_64/update-10.3.1-cos5-x86_64.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/update-rpm-CentOS-5-x86_64/update-10.3.1-cos5-x86_64.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/)/build-10.3.0-rhall-all.hdr.gz
    File downloading SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz: 10%..20%..30%..40%..51%..60%..70%..80%..90%..100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/)/thirdparty-10.3.0-rhall-all.hdr.gz
    File downloading SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz: 100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/)/update-10.3.0-rhall-all.hdr.gz
    File downloading SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz: 100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/)/thirdparty-10.3.0-rhall-all.hdr.gz
    File downloading BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz: 100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/dist-rpm-CentOS-5-x86_64/)/build-10.3.1-cos5-x86_64.hdr.gz
    File downloading PSA_10.3.1/dist-rpm-CentOS-5-x86_64/build-10.3.1-cos5-x86_64.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..91%..100% was finished.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/dist-rpm-CentOS-5-x86_64/build-10.3.1-cos5-x86_64.hdr.gz
    Determining the packages that need to be installed.

    Getting bootstrapper packages to installation list:
    (update package names cache) skip package 'pp10.12.0-bootstrapper-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system pp10.12.0-bootstrapper-10.12.0-cos5.build1012110629.18.x86_64)
    Following bootstrapper packages will be installed: (empty)
    ----------------

    Getting packages to installation list:
    skip package 'plesk-base-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system plesk-base-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'plesk-core-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system plesk-core-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'plesk-l10n-10.12.0-cos5.build1012110727.11.noarch' from component base - there is same or newer version of this package is installed (in system plesk-l10n-10.12.0-cos5.build1012110727.11.noarch)
    skip package 'plesk-skins-10.12.0-11062815.noarch' from component base - there is same or newer version of this package is installed (in system plesk-skins-10.12.0-11062815.noarch)
    skip package 'psa-10.3.1-cos5.build1012110718.17.x86_64' from component base - there is same or newer version of this package is installed (in system psa-10.3.1-cos5.build1012110718.17.x86_64)
    skip package 'psa-awstats-configurator-10.12.0-cos5.build1012110525.15.noarch' from component base - there is same or newer version of this package is installed (in system psa-awstats-configurator-10.12.0-cos5.build1012110525.15.noarch)
    skip package 'psa-libpam-plesk-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system psa-libpam-plesk-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'psa-locale-base-en-US-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-locale-base-en-US-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-logrotate-3.7-cos5.build1012110525.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-logrotate-3.7-cos5.build1012110525.15.x86_64)
    skip package 'psa-mod-fcgid-configurator-2.0.0-cos5.build1012110525.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-mod-fcgid-configurator-2.0.0-cos5.build1012110525.15.x86_64)
    skip package 'psa-mod_fcgid-2.3.6-11052615.x86_64' from component base - there is same or newer version of this package is installed (in system psa-mod_fcgid-2.3.6-11052615.x86_64)
    skip package 'psa-proftpd-1.3.3e-cos5.build1012110526.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-proftpd-1.3.3e-cos5.build1012110526.15.x86_64)
    skip package 'psa-pylibplesk-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system psa-pylibplesk-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'psa-selinux-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-selinux-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-triggers-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-triggers-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-updates-10.3.0-cos5.build1012110525.15.noarch' from component base - there is same or newer version of this package is installed (in system psa-updates-10.3.0-cos5.build1012110525.15.noarch)
    skip package 'psa-vhost-10.12.0-cos5.build1012110601.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-vhost-10.12.0-cos5.build1012110601.18.noarch)
    skip keypackage 'psa-10.3.1-cos5.build1012110718.17.x86_64' from component base - same or newer version of this package is already installed (in system psa-10.3.1-cos5.build1012110718.17.x86_64)
    Following packages will be installed: (empty)
    ----------------
    Patch will not be installed since it is already applied.
    Execute command /usr/local/psa/admin/bin/send-error-report install
    Execute command /usr/sbin/getenforce
    Disabled
    Error: You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.
     
  2. jola

    jola Basic Pleskian

    19
    60%
    Joined:
    Dec 26, 2010
    Messages:
    40
    Likes Received:
    1
    I decided to revert this upgrade and read in a Virtuozzo container backup that I had made before starting the upgrade. Now I'm back on 10.2 again and data from a few hours were lost. I wonder what it was that caused this.

    I suspect that for some reason Plesk was left in a half-upgraded state. At first when I tried to perform the upgrade I had selected PHP 5.3 Support. When that upgrade failed I tried with PHP 5 support. This failed also at first, but then on a second attempt it worked and reported success. Then came the problems with component updates. Do you think that it could be my first attempt to select PHP 5.3 support in the upgrade that can have caused this? I'm hesitant to attempt this upgrade again before I have any idea what caused this failure.

    For information I am running Plesk 10.2 on CentOS 5.6 in a Virtuozzo 4.6 container. Everything is standard in my installation except that I am running PHP 5.2.17 from atomic since my site requires PHP 5.2 or later.
     
    Last edited: Aug 14, 2011
Loading...