1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

500 Internal Server Error

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by fspage, Jan 26, 2012.

  1. fspage

    fspage Guest

    0
     
    My hosting provider did an OS / Plesk reload for me on tuesday (CentOS 6.2 and Plesk 10.4). The control panel was working until last night when I recieved this error when trying to log in "500 - Internal Server Error" I have rebooted the server with no change.

    The sw-cp-server/error_log is as follows:


    2012-01-26 06:03:49: (mod_fastcgi.c.1000) the fastcgi-backend /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm failed to start:
    2012-01-26 06:03:49: (mod_fastcgi.c.1004) child exited with status 1 /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm
    2012-01-26 06:03:49: (mod_fastcgi.c.1007) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
    You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
    For more information check http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
    2012-01-26 06:03:49: (mod_fastcgi.c.1012) If this is PHP on Gentoo add fastcgi to the USE flags
    2012-01-26 06:03:49: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
    2012-01-26 06:25:23: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    Cannot find config item ["global/SERVERsocket==:8443", ".php", 0]

    My server provider ("after intensive investigation") suggests another reload downgrading to CentOS 5 and Plesk 9 so this is a last ditch effort before I down grade. I would appreciate any ideas.

    Thanks
    Scott
     
  2. fspage

    fspage Guest

    0
     
    I found that the /tmp directory was full and after deleting several "repo_transport_tmp_YzEjtE" files the panel is back up.
     
Loading...