1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

500error - fresh install - RewriteEngine

Discussion in 'Plesk for Linux - 8.x and Older' started by dstanley, Aug 28, 2005.

  1. dstanley

    dstanley Guest

    0
     
    This .htaccess worked on the 7.5.3 server it migrated from, perhaps mod_rewrite is not enabled, how do i find out?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    First try running these commands at the SSH prompt and post the results:

    apachectl -t

    locate mod_rewrite.so

    (Not sure what OS you're on, but should work at least on RH OSs)
     
  3. dstanley

    dstanley Guest

    0
     
    am running on suse 9.1

    /usr/lib/apache2/mod_rewrite.so
    /usr/lib/apache2-prefork/mod_rewrite.so
    /usr/lib/apache2-worker/mod_rewrite.so

    t109:/ # /usr/sbin/apache2ctl -t
    Syntax OK
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check your httpd.conf file to make sure it has a LoadModule statement similar to the following:

    LoadModule rewrite_module mod_rewrite.so

    (I say 'similar' since I am not familiar with Suse)
     
  5. dstanley

    dstanley Guest

    0
     
    in the httpd.conf it referenced /etc/apache2/sysconfig.d/loadmodule.conf

    so edited that to include

    LoadModule rewrite_module /usr/lib/apache2-prefork/mod_rewrite.so (this was in the same file on the 7.5.3 server)

    But when i exit and save and do rcapache2 restart

    i check and the line has dissappeared from the file again.
     
  6. dstanley

    dstanley Guest

    0
     
    figured out how to enable mod rewrite for apache

    edit: /etc/sysconfig/apache2

    and add rewrite into the line of modules.
     
Loading...