1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

7.5.4 upgrade failed (Failed dependencies)

Discussion in 'Plesk for Linux - 8.x and Older' started by mmcbee, Sep 6, 2005.

  1. mmcbee

    mmcbee Guest

    0
     
    I am on FC 2 wtih 7.5.3 on

    error: Failed dependencies:
    perl(Mail::SpamAssassin::NoMailAudit) is needed by (installed) psa-spamassassin-7.5.3-fc2.build75050506.13
    perl(Mail::SpamAssassin) is needed by (installed) psa-spamassassin-7.5.3-fc2.build75050506.13
    perl(Mail::SpamAssassin::ArchiveIterator) is needed by (installed) psa-spamassassin-7.5.3-fc2.build75050506.13
    perl(Mail::SpamAssassin::perMsgLearner) is needed by (installed) psa-spamassassin-7.5.3-fc2.build75050506.13
    spamassassin >= 2.60 is needed by (installed) psa-spamassassin-7.5.3-fc2.build75050506.13


    Current components is as follows

    psa 7.5.3-fc2.build75050506.13

    httpd 2.0.51-2.9

    bind 9.2.3-13

    courier-imap 3.0.8-fc2.build75050506.13

    frontpage 5.0.2.2634

    mailman 2.1.5-10.fc2

    mysql 4.0.25-1.rhfc2.art

    postgresql-server Component was not installed

    webalizer 2.01_10-22

    php 4.3.11-8.rhfc2.art

    psa-migration-manager 7.5.3-fc2.build75050506.18

    SSHTerm 0.2.2-fc2.build75050506.13

    spamassassin 3.0.3-1.rhfc2.art

    psa-qmail 1.03-fc2.build75050506.13

    psa-qmail-rblsmtpd 0.70-fc2.build75050506.13

    psa-proftpd 1.2.10-fc2.build75050506.13

    psa-logrotate 3.7-fc2.build75050506.13

    psa-spamassassin 7.5.3-fc2.build75050506.13

    mod_perl 1.99_12-2.1

    perl-Apache-ASP 2.57-fc2.build75050506.13

    psa-bu 7.5.3-fc2.build75050506.13

    psa-api-rpc 7.5.3-fc2.build75050602.16

    What should I do or should I say how?

    Thanks

    Mike
     
  2. mmcbee

    mmcbee Guest

    0
     
    I got it to work I had both psa and art spamassassin

    I removed (in order)
    rpm -e psa-spamassassin
    and then
    rpm -e spamassassin

    Then 7.5.4 upgraded successufully

    I then went back and installed spamassassin from the PLESK update screen

    ;)
     
Loading...