1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.0 Upgrade - Failed dependency on Spamassassin

Discussion in 'Plesk for Linux - 8.x and Older' started by davidbferguson, Mar 30, 2006.

  1. davidbferguson

    davidbferguson Guest

    0
     
    I have attempted the update a couple of times now, first through the Control Panel and just now via the command line, but I get the following error:
    Code:
    Start packages installation
    Install package mod_jk-ap20, psa, psa-locale-base-en-US, psa-api, psa-autoinstaller, psa-libpam-plesk, psa-firewall, psa-backup-manager, psa-watchdog, psa-manual-custom-skin-guide, psa-migration-manager, psa-spamassassin, psa-api-rpc, psa-tomcat-configurator, psa-agent
    error: Failed dependencies:
            spamassassin >= 3.0.0 is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
            perl(Mail::SpamAssassin) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
            perl(Mail::SpamAssassin::ArchiveIterator) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
            perl(Mail::SpamAssassin::Message) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
            perl(Mail::SpamAssassin::PerMsgLearner) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    Error while execute command rpm -U /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/java/mod_jk-ap20-1.2.15-42psa.fc2.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-8.0.0-fc2.build80060329.02.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-locale-base-en-US-8.0.0-fc2.build80060329.02.noarch.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-api-8.0.0-fc2.build80060329.11.noarch.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/updater/psa-autoinstaller-3.0.1-build060327.18.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-libpam-plesk-8.0.0-fc2.build80060329.02.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/modules/firewall/psa-firewall-1.0.1-fc2.build80060329.02.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/backup/psa-backup-manager-8.0.0-fc2.build80060329.11.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/modules/watchdog/psa-watchdog-2.0.0-fc2.build80060329.02.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/docs/psa-manual-custom-skin-guide-8.0.0-fc2.build80060329.02.noarch.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/migration/psa-migration-manager-8.0.0-fc2.build80060329.11.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/mail/psa-spamassassin-8.0.0-fc2.build80060329.02.i586.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/api/psa-api-rpc-8.0.0-fc2.build80060329.11.noarch.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/java/psa-tomcat-configurator-8.0.0-fc2.build80060329.02.noarch.rpm /home/download/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/api/psa-agent-1.4.0-80060329.02.noarch.rpm
    ERROR: error while executing RPM
    ERROR: Installation failed
    
    Doing spamassassin -V gives me:
    SpamAssassin version 3.1.0
    running on Perl version 5.8.3

    So I don't quite understand where it's going wrong!
     
  2. Highland

    Highland Guest

    0
     
    Did you upgrade SA by RPM or Yum?
     
  3. davidbferguson

    davidbferguson Guest

    0
     
    I may have done :)

    I take it I now need to uninstall it before upgrading...
     
  4. davidbferguson

    davidbferguson Guest

    0
     
    Thanks for the tip! A "yum remove spamassassin" fixed it and I'm now running Plesk 8.0 :)

    Now I just need to make sure I can get SA up and running again...
     
  5. Highland

    Highland Guest

    0
     
    Just run

    #yum install spamassassin

    ;)
     
  6. Forza

    Forza Guest

    0
     
    i managed to succesfully remove spamassassin with the yum command. After i removed it I went to the Plesk CP to update to 8.0. However my email still dont seem to work. How do i know if its upgrading now? Or what do i have to do to make my email work again?
     
  7. davidbferguson

    davidbferguson Guest

    0
     
    After removing SA then upgrading then reinstalling SA, I had to go and reactivate Spam Filtering for each mailbox via Domains > {domain} > Mail > {mail name} > Mailbox > Enable spam filtering.

    Make sure SpamAssassin is running too under Service Management!

    Took me a while to work out myself!
     
  8. Forza

    Forza Guest

    0
     
    well what i did was remove spamassassin via the yum remove spamassassin command.

    Then i went to the 7.5.4 updater and installed spamassassin support. But while doing this i didnt get an email with a status report.

    Then i went to plesk 8.0.0 updater and tried to update but, again, i didnt get a status report email. So i dont know how to make this work. My server just don't sends out any emails.
     
  9. omegauser

    omegauser Guest

    0
     
    Spam assassin is not working in my server, when I tried to start the service, it says:
    Starting spamd: [13496] error: Error creating a DNS resolver socket: Invalid argument at /usr/lib/perl5/vendor_perl/5.8.3/Mail/SpamAssassin/DnsResolver.pm line 202.
    Error creating a DNS resolver socket: Invalid argument at /usr/lib/perl5/vendor_perl/5.8.3/Mail/SpamAssassin/DnsResolver.pm line 202.


    any ideas???
     
Loading...