1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.1.0 to 8.1.1 upgrade failed - DO NOT UPGRADE IF YOU DONT HAVE TO!!!

Discussion in 'Plesk for Linux - 8.x and Older' started by jaredfine, Mar 30, 2007.

  1. jaredfine

    jaredfine Guest

    0
     
    8.1.0 to 8.1.1 upgrade failed

    I received an auto success report but when I attempted to log in the plesk server wasn't running so I ssh'd and restarted psa. When I logged in plesk still shows 8.1.0 but now when I click updater and click install I see:

    ERROR: PleskFatalException
    Undefined release.

    0: /usr/local/psa/admin/plib/common_func.php3:151
    psaerror(string 'Undefined release.')
    1: /usr/local/psa/admin/htdocs/server/autoinstaller_install.php:16

    So I figured I'd go download the RPM and perhaps try installing the upgrade from the command line, but low and behold, the website login is broken.

    https://register.swsoft.com/login.php

    "System error: Cannot connect to authorization service. Please try again later. Please contact support@swsoft.com"

    The iceing on the f*cking cake is that when you email the address you get a bounce that says you need a ticket number!

    Amazingly frustrating. I sincerely hope someone from SWSoft reads this thread.

    Needless to say I won't be upgrading any of my other machines to 8.1.1.

    Also, if anyone can help by providing a direct link to the RPM or perhaps has had a similar issue and has figured out a solution, I would truly appreciate the help.

    System info below:

    CPU GenuineIntel, Intel(R) Celeron(TM) CPU 1300MHz
    Version psa v8.1.0_build81070224.19 os_RedHat el3
    OS Linux 2.4.21-47.0.1.EL

    awstats 6.5-2.swsoft
    bind 9.2.4-20.EL3
    coldfusion Component was not installed
    coldfusion-support 8.1.0-rhel3.build81061129.22
    courier-imap 3.0.8-rhel3.build81070322.16
    drweb Component was not installed
    drweb-qmail Component was not installed
    frontpage 5.0-72psa.rhel3
    httpd 2.0.46-61.ent
    mailman 2.1.5.1-25.rhel3.7
    mod_perl 1.99_09-10.ent
    mod_python 3.0.3-5.ent
    mysql 3.23.58-16.RHEL3.1
    perl-Apache-ASP 2.57-rhel3.build81061129.22
    php 4.3.2-39.ent
    postgresql-server 7.3.18-1
    psa 8.1.0-rhel3.build81061129.22
    psa-api-rpc 8.1.1-rhel3.build81070322.16
    psa-autoinstaller 3.1.2-build31070321.17
    psa-backup-manager 8.1.1-rhel3.build81070322.16
    psa-horde 3.1.3-rhel3.build81070201.15
    psa-imp 4.1.3-rhel3.build81061129.22
    psa-logrotate 3.7-rhel3.build81070322.16
    psa-manual-custom-skin-guide 8.1.0-rhel3.build81061129.22
    psa-migration-manager 8.1.1-rhel3.build81070322.16
    psa-miva Component was not installed
    psa-mod-fcgid-configurator 1.0-13
    psa-proftpd 1.3.0-rhel3.build81070322.16
    psa-qmail 1.03-rhel3.build81070322.16
    psa-qmail-rblsmtpd 0.70-rhel3.build81061129.22
    psa-rubyrails-configurator 1.1.6-rhel3.build81061129.22
    psa-spamassassin 8.1.0-rhel3.build81061129.22
    psa-tomcat-configurator 8.1.0-rhel3.build81061129.22
    psa-turba 2.1.3-rhel3.build81061129.22
    ruby 1.8.5-200610081528
    samba 3.0.9-1.3E.12
    spamassassin 3.1.0-1
    SSHTerm 0.2.2-rhel3.build81061129.22
    tomcat 4.1.24-full.2jpp
    webalizer 2.01_10-15.ent
     
  2. jaredfine

    jaredfine Guest

    0
     
    Turns out that error message is the standard error message if you don't have the proper credentials. I tried a few more passwords and eventually found the one I used. I think that message should be made clearer, perhaps "Incorrect Login" would be a better choice?

    Also, while reading the release notes I noticed in bold about half way down the page, "ATTENTION: To upgrade to Plesk 8.1 from previous versions you need to use upgrade through Auto-installer Console Utility because previous versions of Plesk uses an old version of Auto-installer which don't know about new distribution(via FreeBSD ports)."

    So I'm installing via the command line autoinstaller. I'll report back with my results.
     
  3. jaredfine

    jaredfine Guest

    0
     
    Welp it failed.

    Download file opt/modules/atis/psa-atis-1.0-38.noarch.rpm: 16%..100% done.
    Start packages installation
    Install package psa-awstats-configurator-1.0.0-rhel3.build81070322.16.noarch
    Install package psa-horde-3.1.3-rhel3.build81070322.16.noarch
    Install package psa-hotfix2-8.1.1-1.noarch
    error: Failed dependencies:
    psa-hotfix2 = 8.1.0 is needed by (installed) psa-8.1.0-rhel3.build81061129.22
    ERROR: Error while execute command rpm -U /root/swsoft/PSA_8.1.1/dist-rpm-RedHat-el3-i386/base/psa-hotfix2-8.1.1-1.noarch.rpm
    Errors just before:
    - Error while execute command rpm -U /root/swsoft/PSA_8.1.1/dist-rpm-RedHat-el3-i386/base/psa-hotfix2-8.1.1-1.noarch.rpm
     
  4. jaredfine

    jaredfine Guest

    0
     
    Welp, I downloaded the big ole rpm tar and rpm -Uvh --force through all the main RPMs and now I'm good to go.
     
  5. Outlaw

    Outlaw Guest

    0
     
  6. jaredfine

    jaredfine Guest

    0
     
    Outlaw,

    You may be correct. Although when the updater sent the success report I did log into the machine via SSH and check to make sure rpm and autoinstaller weren't running, which they both appeared not to be. After which I restarted PSA. But its entirely possible that something else was happening at the time and if I had waited it may have completed.

    I may have been a little confused by the new autoinstaller messages. In the past it used to say "Auto install started" then I would receive a second email which stated weither it failed or succeed. I don't know why, but now it seems like the first email they send out says that it Succeeded and then they send a second one when it accually Fails or Succeeds.

    In any event I upgraded a 7.5.4 box to 8.1.1 via the command line autoinstaller with no problems. It is nice to actually see whats going on and I suspect that I will make sure that if I'm ever doing a base upgrade again that I use that process.

    I tried editing out my topic above to remove the "don't install language", but I guess they only have message editing turned on. If any ops read this they can feel free to edit my topic.
     
Loading...