1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem after upgrade 10.4.4.->11.0.9

Discussion in 'Plesk 11.x for Linux' started by miskoo, Jul 4, 2012.

  1. miskoo

    miskoo Guest

    0
     
    Hello,

    I have upgraded from 10.4.4. to 11.0.9 by modifying 10.4.4 to 11.0.9 in /etc/apt/sources.lst (debian squeeze).

    after upgrade, following happened:

    1) http://server:8443/ was cycled redirecting to itself, still says plesk is still 10.4.4
    2) after some experiments dpkg removed package psa, because of dependency problem:
    psa: Depends: pp-sitebuilder (>= 11.0.0) but 10.4.4-36793.11110312 is installed.

    So i had to install psa_11.0.9-debian6.0.build110120608.16_i386.deb manually (--force-all)

    Now, plesk interface works, but still says it's 10.4.4 and has a license problems.

    Any help?

    ii libapache2-mod-aclr2-psa 12021319-9e86c2f Module for Apache2 to automate serving static content with NGINX
    ii libapache2-mod-fcgid-psa 2.3.6-12050315 Alternative FastCGI module for Apache2
    ii psa 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 core files
    ii psa-api-rpc 10.0.0-1 Transitional package for psa-api-rpc
    rc psa-atis 1.0-50 Acronis True Image Server for Parallels Plesk Control Panel
    ii psa-autoinstaller 3.12.0-120601.16 Parallels Products Installer
    ii psa-awstats-configurator 11.0.9-debian6.0.build110120606.18 Parallels Panel v11.0.9 awstats configurator
    ii psa-backup-manager 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 Backup Manager
    ii psa-backup-manager-vz 11.0.0-debian6.0.build110120123.10 PVC oriented Parallels Panel v11.0.0 Backup Manager
    ii psa-coldfusion-support 11.0.0-debian6.0.build110110929.10 ColdFusion support for Parallels Panel
    ii psa-courier-imap 3.0.8-debian6.0.build1013111101.14 Courier-IMAP v3.0.8 IMAP server
    rc psa-courier-imap-add 8.6.0-debian4.0.build86081001.10 courier-imap-add
    ii psa-cs-gs 2.0.0-debian6.0.build1013111102.18 Battlefield 2 game server module for Parallels Panel
    ii psa-drweb-configurator 11.0.9-debian6.0.build110120608.16 DrWeb antivirus for checking mail
    ii psa-fileserver 11.0.9-debian6.0.build110120608.16 The Parallels Panel Fileserver module helps your share directories in network
    ii psa-ftputil 1:2.1.1-1.11092910 Plesk-packaged version of ftputil module
    ii psa-horde 3.3.13-debian6.0.build110120606.18 The Horde framework adopted for Parallels Panel
    ii psa-imp 4.3.11-debian6.0.build110120606.18 Web Based IMAP Mail Program for Parallels Panel
    ii psa-ingo 1.2.6-debian6.0.build110120606.18 The Horde email filter rules manager for Parallels Panel
    ii psa-kav 11.0.9-debian6.0.build110120608.16 Transitional Kaspersky Anti-Virus module for Parallels Panel
    ii psa-kav8 8.0.3-0.303893 Kaspersky Anti-Virus for mailservers module for Parallels Panel
    ii psa-kronolith 2.3.6-debian6.0.build110120606.18 The Horde calendar application for Parallels Panel
    ii psa-libxml-proxy 2.7.8-0.301910 libxml-proxy to libxml2 with large lines number support
    ii psa-locale-base-en-us 11.0.9-debian6.0.build110120615.10 en-US locale (base) for Parallels Panel v 11.0.9
    ii psa-logrotate 3.7-debian6.0.build1013111101.14 Rotates, compresses, removes and mails system log files.
    ii psa-mail-driver-common 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 mail drivers common parts
    rc psa-mail-qc-driver 1.0.0-debian5.0.build95101209.08 Plesk mail qmail-courier_imap driver
    ii psa-mailman-configurator 11.0.9-debian6.0.build110120608.16 Mailman Fixups and Configuration scripts
    ii psa-manual-custom-skin-guide 9.0.1-0.279670 Plesk Custom Skins Guide stub package
    ii psa-migration-agents 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 migration agents
    ii psa-migration-manager 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 migration manager
    ii psa-mimp 1.1.4-debian6.0.build110120418.19 Version of IMP suitable for mobile devices for Parallels Panel
    ii psa-mnemo 2.2.5-debian6.0.build110120606.18 The Horde notes and memos application for Parallels Panel
    ii psa-mod-fcgid-configurator 2.0.0-debian6.0.build1013111101.14 Parallels Panel Alternative FastCGI module for Apache2 configurator
    ii psa-passwd 3.1.3-debian6.0.build1013111101.14 Horde password changing application for Parallels Panel
    ii psa-pear 1.9.4-20110921.11092910 PEAR - PHP Extension and Application Repository
    ii psa-php5-configurator 1.6.2-debian6.0.build110120606.18 Parallels Panel v1.6.2 configurator for php5
    ii psa-proftpd 1.3.4a-debian6.0.build110120606.18 ProFTPD -- Professional FTP Server.
    rc psa-proftpd-inetd 1.3.2e-debian5.0.build95101209.08 ProFTPD -- Setup for inetd operation.
    ii psa-pylibplesk 11.0.9-debian6.0.build110120608.16 Various Python modules used Parallels Panel v11.0.9
    ii psa-qmail 2:1.03-debian6.0.build1013111101.14 qmail Mail Transfer Agent
    ii psa-qmail-rblsmtpd 0.88-debian6.0.build1013111101.14 SPAM blocker for QMail daemon
    rc psa-sbm3 5.0-35 The Sitebuilder Remote Administration Module enables Plesk server owners to manage Sitebuilder systems through Plesk.
    ii psa-spamassassin 11.0.9-debian6.0.build110120608.16 Parallels Panel v11.0.9 SpamAssassin support
    ii psa-spf2 1.2.9-11092910 library for validating mail senders with SPF
    ii psa-sso-configurator 1.0.0-debian4.0.build82070918.10 Plesk configurator for SSO
    ii psa-tomcat-configurator 11.0.9-debian6.0.build110120606.18 Configurator for Tomcat server
    ii psa-turba 2.3.6-debian6.0.build110120606.18 The Horde contact management application for Parallels Panel
    ii psa-vhost 11.0.9-debian6.0.build110120606.18 Parallels Panel v11.0.9 default virtual host and files
    ii psa-vpn 11.0.9-debian6.0.build110120608.16 The Parallels Panel Virtual Private Networking module builds a secure network over insecure channels
    ii psa-watchdog 11.0.9-debian6.0.build110120608.16 The Parallels Panel Watchdog is a module for monitoring services on a UNIX system.
    ii psa11-php-fakepackage 11.0.9-debian6.0.build110120608.16 Parallels Panel fake php package
    Thanks
     
  2. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    You should NEVER attempt to do a Plesk upgrade (or any other package operation, unless you know exactly what you are doing) directly via native package manager. Instead you should always use the Parallels Installer (also known as Autoinstaller).

    Also, if you had anything Plesk-related to modify in /etc/apt/sources.list that means previous run of Autoinstaller most probably wasn't completed normally.

    Now you should run (if you have it):
    # /usr/local/psa/bootstrapper/pp11.0.9-bootstrapper/bootstrapper.sh repair

    And then run Autoinstaller to install any updates if they are available.

    And hope that this will help you.
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Brilliant words!
     
  4. miskoo

    miskoo Guest

    0
     
    This helped, thank you.

    I don't trust the web updater, because when updating from 9 to 10, it broken something and is installing packages of wrong architecture, so after each web upgrade, I have to aptitude reinstall all newly installed packages to get it to work...

    This machine is quite grandmother, since Debian potato (or slink?) and plesk 2 or 3, still updating :)
     
  5. DaniëlB

    DaniëlB New Pleskian

    10
     
    Joined:
    Jul 5, 2012
    Messages:
    4
    Likes Received:
    0
    I have updated to Plesk 11 earlier today, unfortunately it keeps refreshing between 2 pages.
    https://server.com:8443/relay
    https://server.com:8443/login_up.php3?window_id=&requested_url=https://server.com:8443/relay

    I have also

    Guessing that he AutoInstaller is the web link: https://server.com:8443/admin/update/ goes back to the two above links.

    Soo, ehm I'm a bit stuck now, I have my dedicated at http://strato.com/ they seem to have their own mirror to get updates from.
     
  6. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Try /usr/share/plesk-billing/integration --command=repair-all
     
  7. DaniëlB

    DaniëlB New Pleskian

    10
     
    Joined:
    Jul 5, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks for the quick reply, unfortunately it hasn't seem to have helped.
    It seems that something doesn't exist, I have pasted to log file onto PasteBin.com; http://pastebin.com/WJjBAMFS

    I've also tried,
    /usr/share/plesk-billing/integration --command=repair-all --idp-url=https://h1856299.stratoserver.net:8443
    as that was suggested in the log, but came back with the following; http://pastebin.com/jetudQ0q

    I've never had problems updating Plesk since i have my dedicated, this is the first time.
     
  8. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    You can disable SSO with command "/usr/local/psa/bin/sso -d"
    After that you should be able to log in.

    Could you please send me SSH credentials via private message - I'll take a look at your server
     
  9. DaniëlB

    DaniëlB New Pleskian

    10
     
    Joined:
    Jul 5, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks "/usr/local/psa/bin/sso -d" did the trick, what have i exactly disabled now? nothing that can be harmful or anything?
     
  10. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    SSO has been used for transparent navigation between CBM and Plesk. Now you will need to log in twice - first time when you go to Plesk, the second time when you click on any link in Business Operations or Business Setup sections.
    So nothing harmful was disabled, both products should work normally except of this small inconvenience.

    It would be better to fix SSO but I need SSH access even to understand what is happening.
     
  11. hardlink

    hardlink New Pleskian

    13
    35%
    Joined:
    Oct 20, 2011
    Messages:
    21
    Likes Received:
    0
    Upgrade breaks CBM config.php script

    Hi,

    I upgraded to 11.0.9 from 10.3.1 using the Panel and had the same issue with the relay login. Having looked into it myself for a couple of hours, I found the issue.

    It's with the file /opt/plesk-billing/lib/lib-billing/include/config/config.php.

    I looked at the config.example.php along side it as saw that there was no closing tag for the php script. Sure enough, there was a php closing tag "?>" dumped in near the end of the config.php file. I removed it and forced a save (read only file) and then I was able to log in without any apparent issues.

    Not sure where the windows equivilent is but hope that helps someone.

    Chris
     
    Last edited: Aug 20, 2012
  12. RyanSett

    RyanSett New Pleskian

    9
    20%
    Joined:
    Aug 21, 2013
    Messages:
    24
    Likes Received:
    0
    Hey,

    I have not upgraded, but the pre check gives me the following.

    Parallels Panel pre-upgrade check...
    Failed loading /usr/local/lib/php/ZendGuardLoader.so: /usr/local/lib/php/ZendGuardLoader.so: wrong ELF class: ELFCLASS32
    PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
    WARNING: Much CPU time can be consumed if default value of "Interval" setting used in /etc/sw-collectd/collectd.conf . Please check http://kb.parallels.com/en/113711 for details.
    WARNING: There are Panel entities with names stored not in lower case. Please check http://kb.parallels.com/en/5780 and /root/parallels/PSA_11.0.9/examiners/plesk11_preupgrade_checker.log for details.

    Should I fix these before hand? It is a GoDaddy VPS Server using plesk.
     
Loading...