1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.2 to 8.3 upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by corman420, Dec 27, 2007.

  1. corman420

    corman420 Guest

    0
     
    I currently have 8.2.1 installed with xcache and I was wondering what the easiest way to upgrade to 8.3 would be. And lastly, will anything break.

    CentOS
     
  2. bits@

    bits@ Guest

    0
     
    I can't update my Plesk with admin panel 8.2.1 -> 8.3.0

    b) /root/psa/PSA_8.3.0/dist-rpm-CentOS-5-i386/opt/backup/psa-backup-manager-8.3.0-cos5.build83071225.21.i586.rpm
    Installing the package psa-api-rpc-8.3.0-cos5.build83071225.21.noarch, psa-8.3.0-cos5.build83071218.19.i586, psa-api-8.3.0-cos5.build83071225.21.noarch, psa-backup-manager-8.3.0-cos5.build83071225.21.i586, psa-libpam-plesk-8.3.0-cos5.build83071218.19.i586, psa-migration-manager-8.3.0-cos5.build83071225.21.i586
    error: Failed dependencies:
    psa-security = 8.2 is needed by (installed) psa-watchdog-2.0.3-cos5.build82070918.10.i586
    ERROR: Unable to install the requested packages because of package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.


    CentOS 5.0
     
  3. ryanz

    ryanz Basic Pleskian

    24
    73%
    Joined:
    Nov 23, 2002
    Messages:
    91
    Likes Received:
    0
    I had some problems upgrading a CentOS 5x64bit system but in the end everythingh seems to be working fine. See my post here http://forum.swsoft.com/showthread.php?t=50043

    1. Did you originally install using the auto installer from the command line. I think you have problems trying to upgrade using the swsoft auto installer if you installed 8.2.x using ART's yum. In this case I suggest you wait for ART to get his updates ready.

    2. Make sure you download and use the latest swsoft auto installer.

    3. Read the manual at http://download1.swsoft.com/Plesk/Plesk8.3/Doc/en-US/plesk-8.3-unix-installation-guide/index.htm

    4. Take note of auto installer command line options at
    http://download1.swsoft.com/Plesk/Plesk8.3/Doc/en-US/plesk-8.3-unix-installation-guide/index.htm

    5. Please make sure that your network allows communication to ka.swsoft.com:5224

    6. Disable SELinux

    7. It might be a good idea to include the url for your source OS packages. You can add this to the Updater in the Admin Panel or in the auto installer command line option.
    For CentOS 5 64bit I used http://mirror.centos.org/centos/5/os/x86_64/CentOS/ be sure to check for your original package url according to your OS.

    Hope this helps.
     
  4. bits@

    bits@ Guest

    0
     
    I installed all new packages with command line without any problem....
    using console...
     
  5. corman420

    corman420 Guest

    0
     
    What commands did you use? And please don't hi-jack my thread. lol. I was asking questions!
     
  6. bits@

    bits@ Guest

    0
     
    1. Reinstall autoinstaller from Plesk 8.2.1

    rpm --oldpackages -Uhv psa-autoinstaller-3.2.1-build32070914.16.i586.rpm


    2. Run autoinstaller
    /usr/local/psa/admin/bin/autoinstaller

    3. Select pkg and install them

    Select the desired products and their versions
    ===============================================================================

    The following product versions are available:

    1. [*]
    2. (*) Plesk 8.3.0




    =====
    good luck!
     
  7. corman420

    corman420 Guest

    0
     
    So do you think this will break my xcache?
     
Loading...