1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

A many Errors after Update from 10.3 to 10.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by HeinsM, Nov 23, 2011.

  1. HeinsM

    HeinsM Guest

    0
     
    Hy.

    now i cant use the Plesk.... on every site i become a error massage... on start page come this error:

    Code:
    Internal error: Specified column "version" is not in the row
    Message 	Specified column "version" is not in the row
    File 	Abstract.php
    Line 	179
    Type 	Zend_Db_Table_Row_Exception
    Zur vorherigen Seite 
    
    and the log file say this:

    Code:
    PHP Warning:  file_get_contents(/root/.autoinstaller/microupdates.xml): failed to open stream: Permission denied in /opt/psa/admin/sbin/logmng on line 49
    2011-11-23T18:26:10+01:00 CRIT (2): Zend_Db_Table_Row_Exception: Specified column "version" is not in the row
    file: /opt/psa/admin/plib/Zend/Db/Table/Row/Abstract.php
    line: 179
    code: 0
    2011-11-23 18:26:10: (mod_fastcgi.c.2588) FastCGI-stderr: PleskUtilException: /opt/psa/admin/bin/logmng '/root/.autoinstaller/microupdates.xml' failed with message: Invalid log file /root/.autoinstaller/microupdates.xml requested
    file: /opt/psa/admin/plib/common_func.php3
    line: 1047
    code: 0
    trace: #0 /opt/psa/admin/plib/common_func.php3(965): util_exec('logmng', Array, Array, 'lst', NULL)
    #1 /opt/psa/admin/plib/Os.php(17): smart_exec('logmng', Array, Array, 'lst')
    #2 /opt/psa/admin/plib/CommonPanel/Update/Patch.php(15): Os::exec('logmng', Array, 'lst')
    #3 /opt/psa/admin/plib/CommonPanel/Controller/Helper/Update.php(32): CommonPanel_Update_Patch::getVersion()
    #4 /opt/psa/admin/panel/application/controllers/HomeController.php(119): CommonPanel_Controller_Helper_Update::getSystemOverview(Object(Zend_View))
    #5 /opt/psa/admin/panel/application/controllers/HomeController.php(42): HomeController->_prepareSystemOverview()
    #6 /opt/psa/admin/plib/Zend/Controller/Action.php(513): HomeController->adminAction()
    #7 /opt/psa/admin/plib/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('adminAction')
    #8 /opt/psa/admin/plib/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #9 /opt/psa/admin/panel/application/library/AdminPanel/Application/Web.php(20): Zend_Controller_Front->dispatch()
    #10 /opt/psa/admin/panel/application/public/index.php(15): AdminPanel_Application_Web->run()
    #11 {main}
    
    Zend_Db_Table_Row_Exception: Specified column "version" is not in the row
    file: /opt/psa/admin/plib/Zend/Db/Table/Row/Abstract.php
    line: 179
    code: 0
    trace: #0 /opt/psa/admin/plib/Db/Table/Row.php(89): Zend_Db_Table_Row_Abstract->__get('version')
    #1 /opt/psa/admin/plib/CommonPanel/Controller/Helper/Update.php(57): Db_Table_Row->__get('version')
    #2 /opt/psa/admin/panel/application/controllers/HomeController.php(119): CommonPanel_Controller_Helper_Update::getSystemOverview(Object(Zend_View))
    #3 /opt/psa/admin/panel/application/controllers/HomeController.php(42): HomeController->_prepareSystemOverview()
    #4 /opt/psa/admin/plib/Zend/Controller/Action.php(513): HomeController->adminAction()
    #5 /opt/psa/admin/plib/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('adminAction')
    #6 /opt/psa/admin/plib/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #7 /opt/psa/admin/panel/application/library/AdminPanel/Application/Web.php(20): Zend_Controller_Front->dispatch()
    #8 /opt/psa/admin/panel/application/public/index.php(15): AdminPanel_Application_Web->run()
    #9 {main}
    
     
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,560
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Looks like unsuccessfully completed upgrade. Did you try bootstrapper repair?
     
  3. HeinsM

    HeinsM Guest

    0
     
    how can i make this?
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,560
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Try to search 'bootstrapper repair' in KB articles at least.
     
  5. MaxZ

    MaxZ Guest

    0
     
    Had the same issue, just to confirm, "bootstrapper.sh repair" does fix it, works fine afterwards.
     
Loading...