1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

A simple PHP script won't work

Discussion in 'Plesk for Linux - 8.x and Older' started by David Joor, Mar 22, 2005.

  1. David Joor

    David Joor Guest

    0
     
    I just got a plesk server and now I am having a hell of a time getting variables posted back to the php page once submitted. I can't get the script to read the variable after it has been submitted. Basically the text doesn't get printed to screen. I have no problem with this on ensim, this is so basic that I am lost. Running 4.3.10 php and httpd-2.0.46-44.ent

    Code:
    <?PHP
    if ($btnSubmit != "") {
         echo "You have pressed the submit button";
    }
    ?>
    
    <form method="POST" action="<? print $_SERVER['SCRIPT_NAME'];?>">
    <input type="submit" name="btnSubmit" value="push me"> 
    </form>
    
     
  2. David Joor

    David Joor Guest

    0
     
    Someone helped me at ev1servers forum. The problem was in my php.ini file.

    Need to set it to this.
    Code:
    register_globals = On
    it was off.
     
  3. alexv

    alexv Guest

    0
     
    I'd leave the "register_globals = Off"

    and would change the "if" statement to:

    . . .
    if ($_POST["btnSubmit"] != "") {
    . . .


    It's much more secure.
     
Loading...