1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

access denied error on removal of a www-data created file

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by nadygee, May 11, 2011.

  1. nadygee

    nadygee Guest

    0
     
    Hi!

    I have the following problem. If I try to remove a file (via ftp or plesk filemanager) created by a website running on vhost (user:www-data group:www-data permission:rw r-- r--), I get the following:
    Removal is successful using the website (eg. using joomla backend),
    I found a suggestion about change to run PHP as FastCGI application instead of Apache module. But after change the files created earlier by www-data cannot be read from website. And if I install a joomla/gallery etc. application, FastCGI option changes back to Apache module.

    How can I setup plesk panel to be able to remove/modify these files?
    Thanks in advance.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    The problem is that Filemanager is working with privileges of FTP user of the site, however directories on top level of domain directory structure belong to 'psaserv' group which FTP user is not a member of (and should not be due to security reasons.)

    This is done because directories on the top level of domain directory structure are not supposed to be managed manually. Especially directories in which websites are hosting already.

    Nevertheless we have request to product maintenance team to improve error-reporting in future versions of Plesk. Also, in case if directory is not hosting any websites and is not service directory required by Plesk, it should be removable.
     
  3. nadygee

    nadygee Guest

    0
     
    Thanks for the answer.
    So is there ANY method to modify/delete those files created by the website? It's really important?
     
  4. Adam Jones

    Adam Jones Guest

    0
     
    nadygee; did you get any fixes to this?
    i have to delete the files via a terminal window using rm -rf but I wanted a solution so that web users of could do this themselves.

    Thanks
     
  5. menelrana

    menelrana Guest

    0
     
    Error 550

    When I upload a file via my website, file created cannot be delete by ftp, neither by plesk file manager.
    The user change in the directory recently created with my websiteupload but this ftp user group doesn't exist anywhere in my plesk.
    How can i solve this problem, upper folder can't be delete nor rename then
     
  6. DimitriyH

    DimitriyH Guest

    0
     
    Is there any updates on this issue?
    I have a same problem. I need to use CGI/FastCGI, when uploading files via php script(Wordpress media library plugin) I can't modify/delete files using FTP. However I can upload/modify/delete files with FTP(but only files uploaded directly using FTP). It seem like file is locked, however it is not.
    Parallels??

    P.S. Owner of uploaded files(via script) are correct, the same with permission(I even tried to set 7777).
    update: My issue was resolved by re-creating FTP account.
     
    Last edited by a moderator: Apr 22, 2012
  7. joomlabuilder

    joomlabuilder Guest

    0
     
    I unzipped my site using a php script, and now I'm 'locked out' of my FTP because all those files are owned by www-data, is there anything I can do to get control over my sites files on FTP?

    Please help!
     
  8. DimitriyH

    DimitriyH Guest

    0
     
    I believe Apache is running under that user, so you can try to use php as CGI or Fast-CGI instead of Apache module. In this case all files, that will be uploaded using scripts, will be owned by your username, e.g. you will be able to delete them using FTP client.
     
  9. GabrielK

    GabrielK New Pleskian

    10
     
    Joined:
    Oct 11, 2012
    Messages:
    1
    Likes Received:
    0
    How about this?

    How about this solution? I'm really considering just having a computer guy help me out with this but I wanted to do a last resort solution.. Has any1 tried pathtoodeep.com's long path tool? Heard it could help..Any information is appreciated :(
     
Loading...