1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Access forbidden after try to upgrade PHP

Discussion in 'Plesk for Linux - 8.x and Older' started by jsedano, Oct 31, 2007.

  1. jsedano

    jsedano Guest

    0
     
    greetings!

    I was trying to upgrade the php version manualy on my server (CentOS4) using a RPM package, after that I cant access to Plesk, i got a 403 error

    Its a dedicated server with godaddy, i made a phpinfo() file to test if my upgrade worked but it seems that i still have PHP Version 4.3.9

    also, webmail services stop working

    any ideas how can I fix this?

    I already do what http://kb.swsoft.com/en/1762 says

    (in CentOS we have yum instead of apt-get)

    update:
    I manage to upgrade php to version 5.2 following this guide: http://www.atomicorp.com/wiki/index.php/PHP
    but I still have the 403 error :(
     
  2. anb_t

    anb_t Guest

    0
     
    Note that Plesk is distributed with its own apache and php that serve the control panel interface, they do not affect client apache and client php that serve websites and scripts under virtual domains.
    Plesk support strongly do not recommend to upgrade or change configuration for admin apache or php as it could brake the control panel itself.
    Most likely you upgraded client php exactly that can not affect the control panel.. The knowledge base article mentioned was true for PHP upgrade on Debian, apt-get tries to remove main Plesk deb package 'psa' with all dependencies.

    Just check permissions to Plesk DocumentRoot set in admin apache configuration:

    ~# grep DocumentRoot /usr/local/psa/admin/conf/httpsd.conf
    DocumentRoot "/usr/local/psa/admin/htdocs"
    ~# ls -ld /usr/local/psa/admin/htdocs
    drwxr-xr-x 23 root root 4096 Sep 26 23:11 /usr/local/psa/admin/htdocs
    ~#

    Also.. check SELinux status:

    ~# /usr/sbin/getenforce

    and Plesk apache error log file for more details /usr/local/psa/admin/logs/httpsd_error_log

    ./anb
     
  3. jsedano

    jsedano Guest

    0
     
    Thanx for reply

    the file DocumentRoot /usr/local/psa/admin/conf/httpsd.conf was empty, so I added the line:
    DocumentRoot "/usr/local/psa/admin/htdocs"

    then I check for the file permitions, got this:

    [root@netkserver logs]# ls -ld /usr/local/psa/admin/htdocs
    drwxr-xr-x 9 root psaadm 4096 Oct 31 09:22 /usr/local/psa/admin/htdocs


    and finaly, after doing a /usr/sbin/getenforce responds: Disabled

    Some of the error log:

    [Wed Oct 31 15:39:27 2007] [error] [client xxx.xxx.xxx.xxx] File does not exist: /usr/local/psa/admin/htdocs/javascript/promo-flags.js.php
    [Wed Oct 31 15:47:00 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Wed Oct 31 15:47:00 2007] [error] OpenSSL: error:1407609C:SSL routines:func(118 ):reason(156)
    [Wed Oct 31 15:47:02 2007] [error] [client xxx.xxx.xxx.xxx] Directory index forbi dden by rule: /usr/local/psa/admin/htdocs/
    [Wed Oct 31 17:28:13 2007] [error] [client xxx.xxx.xxx.xxx] Directory index forbi dden by rule: /usr/local/psa/admin/htdocs/
    [Thu Nov 1 07:20:14 2007] [error] [client xxx.xxx.xxx.xxx] Directory index forbi dden by rule: /usr/local/psa/admin/htdocs/
    [Thu Nov 1 07:58:23 2007] [error] [client xxx.xxx.xxx.xxx] Directory index forbi dden by rule: /usr/local/psa/admin/htdocs/
    [Thu Nov 1 07:58:23 2007] [error] [client xxx.xxx.xxx.xxx] File does not exist: /usr/local/psa/admin/htdocs/favicon.ico


    After that I did a httpd restart, but still nothing.
     
  4. anb_t

    anb_t Guest

    0
     
    Check content of Plesk document root /usr/local/psa/admin/htdocs. Apache error 'Directory index forbidden by rule' means that the directory does not have the DirectoryIndex file.

    ~# grep DirectoryIndex /usr/local/psa/admin/conf/httpsd.conf
    DirectoryIndex index.html index.php index.php3
    ~#
    ~# ls -l /usr/local/psa/admin/htdocs | grep -E 'index.html|index.php|index.php3'
    -rw-r--r-- 1 root psaadm 3849 18 10:28 index.php
    ~#

    Also check consistency of base Plesk package:

    ~# rpm -V psa | grep /usr/local/psa/admin/htdocs
    ~#

    and group psaadm:

    ~# grep -E 'psaadm|psaserv' /etc/group
    psaadm:x:2521:psaadm
    psaserv:x:2523:apache,psaftp,psaadm
    ~#

    ./anb
     
  5. jsedano

    jsedano Guest

    0
     
    Thanks for the time you're taking to help me.

    I have the following files in in the /usr/local/psa/admin/htdocs directory:

    backup enterprise index.php modules sshterm
    bu_pubkey.txt images locales schemas


    should it be something else there?

    the ls -l /usr/local/psa/admin/htdocs | grep -E 'index.html|index.php|index.php3' command didnt return me any answer.

    I made a index.php file with a <?echo "Hello";?> command for testing, and the Forbidden msg disapear, but it didnt show me the hello msg, just a blank page.

    best regards.
     
  6. gorilych

    gorilych Guest

    0
     
    try to reinstall psa.rpm with

    rpm --force --noscripts /path/to/psa/rpm

    then try:

    /etc/init.d/psa start
     
  7. jsedano

    jsedano Guest

    0
     
    psa.rpm is nowhere in the server :(

    Also, there's no service with the name of psa in /etc/init.d

    anyway, its too late for me to try to fix this mess, the company its about to format and reinstall everything from scratch.

    thank you everyone!
     
Loading...