1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Add a database server fails - mysqlnd cannot connect to MySQL 4.1+ error

Discussion in 'Plesk 11.x for Linux' started by sismservice, Oct 3, 2012.

  1. sismservice

    sismservice New Pleskian

    22
    23%
    Joined:
    May 16, 2007
    Messages:
    5
    Likes Received:
    0
    We have a Plesk 11.0 server and we want to use a separate DB server. See server details below:

    Webserver:
    Redhat EL 5.8-64
    Parallels Plesk - 100 Domain w/ Power Pack 11.0.9 Linux
    mysql 5.0.95-1.el5_7.1

    DB Server:
    Redhat EL 5.8-64
    NO Plesk
    mysql 5.0.95-1.el5_7.1

    When we attempt to "Add Database Server" and complete the information we get the following error:

    "Error: Test connection to the database server has failed:

    mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file"

    Anyone have a suggestion?

    We did find this info:
    http://stackoverflow.com/questions/...ysql-4-1-using-the-old-insecure-authenticatio

    But the MySQL GUI Tools (http://dev.mysql.com/downloads/gui-tools/5.0.html) referenced are no longer available.

    Has anyone been successful in adding a database server in a similar setup?

    Matt
     
  2. EugeneKazakov

    EugeneKazakov Basic Pleskian Staff Member

    19
     
    Joined:
    Aug 22, 2012
    Messages:
    99
    Likes Received:
    7
    Here is solution, but it is in russian, but queries are clear:
    1. Connect your db-server via ssh
    2. Remove old_passwords = 1 from my.cnf
    3. Open mysql console
    4. Update mysql.user table in order to have valid passwords
     
  3. sismservice

    sismservice New Pleskian

    22
    23%
    Joined:
    May 16, 2007
    Messages:
    5
    Likes Received:
    0
    Thank You - I have confirmed this worked -
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
Loading...