• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

" '--add' is not a command" error on registering new php_handler

Michael_Zorn

New Pleskian
This is what I get when I try to register a new PHP handler.
Code:
root@km32511:/usr/local/src/php-5.6.7# /usr/local/psa/bin/php_handler -–add -displayname 5.6.7 -path /usr/local/php567/bin/php-cgi -phpini /usr/local/php567/lib/php.ini -type fastcgi -id fastcgi-5.6.7
'-–add' is not a command

I don't get what I'm doing wrong.

Even
Code:
/usr/local/psa/bin/php_handler -–add

returns the same error.

OS Ubuntu 12.04.5 LTS
Plesk version 12.0.18 Update #39, last updated at Mar 27, 2015 07:51 AM
 
Solved my problem by editing /etc/psa/php_versions.json with a texteditor. But
Code:
php_handler --add
still doesn't work on my machine.
 
You have incorrect coding of '--' symbols:

8017926.png

Just replace it with correct --add
 
Back
Top