1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

AddDefaultCharset not allowed here

Discussion in 'Legacy Sitebuilder Software' started by nathanl, May 2, 2006.

  1. nathanl

    nathanl Guest

    0
     
    I have Sitebuilder running on Linux, it publishes to a FreeBSD server, running apache.
    When sites publish a .htaccess files is created. When i try to load the site once its published, i am given an "internal server error" and apache's error log reports:
    Code:
    /usr/home/sitebuilder/sites/test/.htaccess: AddDefaultCharset not allowed here, referer: [url]http://sitebuildertest.accu-find.com/flashes/intro.html[/url]
    
    I added the character set to the site's virtual directory block in apache's confug, and removed the .htaccess file. the site loads properly that way, but what i need is for this to operate automatically. Having to remove, or rename the .htaccess file upon publish could be a problem later.

    What can i do to make apache use the .htaccess file as it should?

    thank you.
     
  2. nathanl

    nathanl Guest

    0
     
    Nevermind. I found the problem.
    Apache needed me to allow htaccess to set the charset.
    All is well now.
     
Loading...