1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Adding Joomla 2.5.4 to Plesk Errors

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by tiffanyh, May 4, 2012.

  1. tiffanyh

    tiffanyh Guest

    0
     
    After upload on entering Joomla via Plesk - the website - Admin Interface - on attempting to change the global configuration, I receive the following error

    JLIB_APPLICATION_ERROR_COMPONENT_NOT_LOADING
    Could not save data. Error: Could not write to the configuration file
    JLIB_APPLICATION_ERROR_COMPONENT_NOT_LOADING

    After reading up on this I changed The settings for the site from 'PHP Support 'Run as Apache Mode' to 'Run as FastCGI Application'.

    After doing this I could successfully configure Global Configuration 'back end'.

    However, by enabling 'Run as Apache Application' I was unable to add any extenstions using the extensions manager.

    On reverting back to 'Run as Apache Mode' I was able to add extensions. But with the error message

    JLIB_APPLICATION_ERROR_COMPONENT_NOT_LOADING
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,238
    Location:
    Novosibirsk, Russia
    I have installed Joomla 2.5.4 from Application Catalogue to domain on Plesk 10.4.4 MU#28 and tried to switch PHP mode from fastCGI to Apache module and back. And I can't reproduce issue described by you. All works fine for me. Do you have any customizations on your Plesk? How Joomla was installed?
     
  3. tiffanyh

    tiffanyh Guest

    0
     
    Thank Your for fast reply. I installed Joomla 2.5.4 via Plesk installation. On entering Joomla, could not configure global configuration until I had changed to FastGCI and then could not install Joomla Extensions with FastGCI so had to revert back to Apache module. But with the error message as described above. I logged in via Admin Interface using same login details as with Plesk Panel, one click and I was in back end of Joomla. I have worked with Joomla for 2 years using a shared host but have hit these problems since taking my own virtual server? Not a clue what I can do. Your help would be appreciated.
     
Loading...