1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Additional Services and Custom Buttons

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by lhwparis, Mar 31, 2011.

  1. lhwparis

    lhwparis Guest

    0
     
    Bugs: Additional Services and Custom Buttons

    Some things i found sorry for not using the full bug report form but it costs many time to fill it completly for all this bugs.
    Hope you can reproduce the bugs IgorG

    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk, 10.1.1, Ubuntu 10.04, x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    Bug1: if you set an Additional Service in "Service Plans"->"Additional services" it is shown on the "Home" Tab of the CustomerPanel. If you add some custom Buttons to the "Home" Tab too. The additional Services from the Service plan are no longer visible. only the custom buttons are shown!

    Bug2: if i add an "Service Plans"->"Additional service" and use this URL: "../test/index.php" the Link on the Home Tab points to right direction (http://domain.tld:8443/test/index.php) BUT the button in "Websites & Domains" Tab Points to: http://domain.tld:8443/smb/test/index.php so it is not possible to break out from smb directory with "../" if you try to do that the button in Websites & Domains is broken!

    Bug3: Why is it possible to use parameters like Primary Domain name, Subscription ID and some others for additional services but NOT for custom buttons placed at the "Home" Tab? its the identical possion why is there a different behavior?

    Bug4: Why is it possible to "Open URL in Parallels Panel" for custom buttons but this option is not available for "Service Plans"->"Additional services" ??

    Bug5: The bug i reported there: http://forum.parallels.com/showthread.php?t=109449

    Are additional services not nearly the same as custom buttons? Some features are only available for custom buttons some things are only available for addition services... why not merge this two things?

    Feature request1: Why is there this "Additional service" box on home tab? it would be very much cooler their is an own box for each additional service (custom button) with the icon left and the big headline with the name of the additional servce and the description directly visible not only as tooltip! now we have a big headline "additional services" a description which describes what an additional service is and a small little link to the service itself!

    Feature request2: Why is it not possible to add an additional service to a subscription with an Add-on?

    Feature request3: There are no plesk events i can use to run some custom scripts when a subscription with an "addition service" is created :( this would be very helpful.

    Feature request4: Give us more options where we can include additional services like additional tabs in the main navigation of the CustomerPanel for example.
     
    Last edited by a moderator: Mar 31, 2011
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Sorry, but I can't forward this huge collection to developers due to one simple rule - one problem - one report.
     
  3. lhwparis

    lhwparis Guest

    0
     
    arrrr i spent a lot time to post this to help you fixing bugs and all you say is have to spent more time....

    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk, 10.1.1, Ubuntu 10.04, x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    if you set an Additional Service in "Service Plans"->"Additional services" it is shown on the "Home" Tab of the CustomerPanel. If you add some custom Buttons to the "Home" Tab too. The additional Services from the Service plan are no longer visible. only the custom buttons are shown!

    ACTUAL RESULT
    Additional services are only shown on customer home tab when there are no custom buttons. if there are custom buttons and additional services the additional services are not shown

    EXPECTED RESULT
    both, additional services and custom buttons should be shown

    ANY ADDITIONAL INFORMATION
    -
    --------------------------------------------------------------
     
  4. lhwparis

    lhwparis Guest

    0
     
    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk, 10.1.1, Ubuntu 10.04, x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    if i add an "Service Plans"->"Additional service" and use this URL: "../test/index.php" the Link on the Home Tab points to right direction (http://domain.tld:8443/test/index.php) BUT the button in "Websites & Domains" Tab Points to: http://domain.tld:8443/smb/test/index.php so it is not possible to break out from smb directory with "../" if you try to do that the button in Websites & Domains is broken!

    ACTUAL RESULT
    you have to use a full URL (http://...) otherwise there is no way to break out from "smb" directory. if you try it with URL starting with ../ it works on the customer home tab but button in "Websites & Domains" is broken

    EXPECTED RESULT
    it should not break the button in "Websites & Domains" when an URL starts with ../ because it also worked for custom buttons for years

    ANY ADDITIONAL INFORMATION
    -
    --------------------------------------------------------------
     
  5. lhwparis

    lhwparis Guest

    0
     
    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk, 10.1.1, Ubuntu 10.04, x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    Why are there different parameters and options between additional services and custom buttons? it is possible to use parameters like Primary Domain name, Subscription ID and some others for additional services but NOT for custom buttons placed at the "Home" Tab? its the identical posision why is there a different behavior?

    Why is it possible to "Open URL in Parallels Panel" for custom buttons but this option is not available for "Service Plans"->"Additional services" ??

    ACTUAL RESULT
    cant understand why some options are only available for custom buttons and some others only for additional services when they are shown on the exect same possision (CustomerPanel Home Tab)

    EXPECTED RESULT
    it should be possible to use this parameteres for CustomButtons placed on Customer HomeTab too and there should be a way to open an additional service in the plesk panel.

    ANY ADDITIONAL INFORMATION
    Are additional services not nearly the same as custom buttons? Some features are only available for custom buttons some things are only available for addition services... why not merge this two things?
    --------------------------------------------------------------
     
  6. optip

    optip Guest

    0
     
    i wait its solution.
     
  7. lhwparis

    lhwparis Guest

    0
     
    i hope thats ok now and you can reproduce this problems?

    do i have to fill such reports for feature requests too?
    maybe you can say a little what you think about that feature request

    thanks IgorG
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    I will update thread later.
     
  9. lhwparis

    lhwparis Guest

    0
     

    Attached Files:

  10. lhwparis

    lhwparis Guest

    0
     
    Igor any news to this? With all this bugs i cant provide some of my custom services
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    I still haven't any response from developers.
     
  12. lhwparis

    lhwparis Guest

    0
     
    a few weeks ago since last update, 3 micro-updates but still no solution or answer to this?
     
Loading...