1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

All domains display default page

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by dmitrybelyakov, Nov 28, 2010.

  1. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    All domains display webserver's default page

    Hello,

    We've recently installed Plesk 10.1 panel on a new box with one shared IP. We currently have 3 domains running but all of them display the default page although we cleared the httpdocs completely.

    When we preview the site from the panel it displays correctly, but normally from within a browser we get a default page. The mail and ftp services on these domains are fine.

    Thanks for any help or siggestions.
    Dmitry.
     
    Last edited by a moderator: Nov 29, 2010
  2. Justin Clarke

    Justin Clarke Regular Pleskian

    22
    40%
    Joined:
    Mar 3, 2010
    Messages:
    117
    Likes Received:
    0
    Did you get any errors in your update log? Sounds like a similar issue I had when installing Named.
     
  3. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    Hi, Justin.

    Well, it wasn't an update - just a new installation on a fresh box...
     
  4. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    One more thing to mention:

    I wonder if this could be a license issue, since we're on a trial license at the moment.
    And by the way - all the webmail.domain.com stuff works too.
    It's just the www not showing up...

    Dmitry.
     
  5. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    Bump...

    Can anyone please advise me at least where to dig for the possible reason? Why can it be that all the services are working, but apache shows the default page for all the domains we create (including the default one). This is a fresh Plesk 10.1 install so I guess everything should be working fine out of the box but it doesn't.

    This is kind of urgent, so please excuse my bumping up the message.
     
  6. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    One more correction to the issue: the page we see on all domains in the "Web Server's Default Page" (with some parallels ads) not the "Default Plesk Page" from the skeleton.

    Additionally we are actually UNABLE to connect to FTP service via ftp.domain.tld although such DNS record exist. We're only able to connect to domain.tld via FTP.

    So ftp.domain.tld does not work(!).
     
  7. eryan

    eryan Guest

    0
     
    I have the same issue.

    Did you resolve it?

    All domains display the server default webpage from /var/www/index.html

    The domains were working fine, but we had an issue with an erroneous IP on one domain which prevented us from adding new customers. Parallels support finally helped us fix this, but now we have the problem you describe.

    One thing I notice is that in the folder:

    /var/www/vhosts/domain.tld/conf

    we now have files called:

    12921693890.78522800_httpd.include

    rather than:

    httpd.include

    I wonder is this expected in Plesk 10?

    Did you find any other solution?

    Many thanks!
     
  8. dmitrybelyakov

    dmitrybelyakov Guest

    0
     
    Well, it took several days for parallels support to help us resolve the issue. I don't know if that's your case,
    but our issue was related to ip addresses. Generally we had a local network IP assigned to our server instance wich was then aliased with a public IP address (a typical setup for amazon ec2 instances). So the solution was to assign domains to the local ip (not the public one), and then ajust the default dns template to use public ip instead of the one the domain is assigned to.

    Dmitry.
     
  9. eryan

    eryan Guest

    0
     
    Hi dmitrybelyakov

    Thanks for your quick reply, I wish Paralells support were that responsive ;)

    Sounds like our issue may be due to a similar cause.

    We do have a local IP address assigned to another interface, but I don't think that the public IP is aliased, we have two physical interfaces, one public IP , and one local IP, like 192.168.0.2 - so they are on different physical networks.
    The local network is for backups.

    So I'm not sure that we should assign the local IP to the domains in our case. But it certainly sounds related.

    I'll investigate some more and post my findings back.

    Many thanks!
     
  10. DanieleC

    DanieleC Guest

    0
     
    same problem for me, but i solved (excuse my english i'm italian) Plesk after the migration not UNSUSPEND all or some accounts, you must do it manually from the command line, but do not remember how I had found a way to do it by looking at google
     
  11. tcreswick

    tcreswick Guest

    0
     
    We have just upgraded to 10.0.1 from a 9.x release, and all of our "www" aliases are broken.

    For example, if we have a domain "nxdomain.com" listed on Plesk, connections to nxdomain.com work, however connections to www.nxdomain.com show the default page. This sounds like the same error other users are seeing.

    Our situation is complicated by the following points:

    1. By default we disable Plesk DNS as we have an independent (and more robust) DNS implementation
    2. We frequently use reverse-proxy servers, so the A and CNAME records don't necessarily resolve to the Plesk server IP
    3. We do not list 127.0.0.1 in our resolv.conf, since we want to avoid Plesk using any local DNS data, since it should always be defined elsewhere.

    The resolution I have found was thus:

    1. Changed the DNS template so that the default www record is now a CNAME to <domain>. (it was an A record to the server IP before)
    2. Go to the domain administration, enable DNS then "Restore Defaults"
    3. Run /usr/local/psa/admin/bin/httpdmng --reconfigure-domain to regenerate the configuration
    4. Go to the domain administration and disable the DNS

    After performing these steps, it appears that the www.* domain aliases start working again, even with subsequent reconfigurations.

    It would appear that Plesk is doing something strange when figuring out these "hidden" aliases. Can anyone shed any light on the process?

    Do I need to carry out this procedure for ALL of my domains?
     
  12. tcreswick

    tcreswick Guest

    0
     
    Solution

    Further to my previous post I have established that the issue is the use of A record types for www aliases.

    It turns out that Plesk uses these DNS values, regardless of whether DNS is enabled on the domain. If they are not present as CNAME values, the domain alias will not work. I suspect that this default behaviour is different in plesk 10.x, however our existing domains were configured differently prior to the upgrade.

    I couldn't find a way to make a batch change to the domains, so I used the following SQL statement in the psa configuration database to resolve my issue:

    Then I ran this command:

    Any my issue is fully resolved.

    I would still like to know the underlying logic that Plesk is using, since this is not expected behaviour.
     
  13. SoyCreativo

    SoyCreativo Guest

    0
     
    Same problem here

    I have the same problem here, when I try to create a new domain, always the default page of the server is showed. (/var/www/vhosts/default), but the FTP redirection is right.

    When I do an "ls" in conf directory of the new domain (/var/ww/vhosts/domain.com/conf) , the directory is empty, I tried to run the httdpmg reconfigure, but I have the next error :

    root@srv1 bin]# pwd
    /usr/local/psa/admin/bin
    [root@srv1 bin]# ./httpdmng --reconfigure-server
    You entered your username or password incorrect.

    Anybody knows which is the user from the error ? or how can I set one as a parameter
     
Loading...