1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ALL sites password protected

Discussion in 'Plesk for Windows - 8.x and Older' started by FFCus, Mar 12, 2006.

  1. FFCus

    FFCus Guest

    0
     
    ALL sites were password protected - Now just ASP.NET files

    For some reason, all sites on the server have become password protected. Nothing I do seems to get them back to normal. Any ideas what could be causing this?

    I'm stumped. I've tried restoring backups, but that didn't do anything. Any other options you can think of?
     
  2. OlegB

    OlegB Guest

    0
     
    Please check global ISAPI filters.

    IIS > Web Sites > Properties > ISAPI filters tab
    Are there any non standard filters present.

    Also I recommend to check Authenticated access for websites. It seems there a manual intervention into IIS was.

    IIS > Web Sites > Properties > Directory Security tab > Edit Authentication and access control.

    Also you can check the states described in

    http://kb.swsoft.com/article_156_976_en.html
    http://kb.swsoft.com/article_156_558_en.html
     
  3. FFCus

    FFCus Guest

    0
     
    Thanks Oleg.

    Last night nothing was working. This morning I was able to go in and manually reset the passwordds for the IUSR accounts and the sites are no longer PW protected.

    Oddly enough, just ASP.NET pages are protected now - so there must be some missing permissions for that I need to figure out.

    Thanks again.
     
  4. FFCus

    FFCus Guest

    0
     
    When I go to Server>ASP.NET, I get the following error:

    Code:
    ASPdotNet() constructor failed: aspnetcfg failed: Empty error message from utility.
    ---------------------- Debug Info -------------------------------
    0: C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\aspdotnet.php:72 psaerror(string "ASPdotNet() constructor failed: aspnetcfg failed: Empty error message from utility.")
    
    How do I fix this?
     
  5. FFCus

    FFCus Guest

    0
     
    More Info...

    When I ran the reconfigurator, errors such as the following popped up for every domain:

    C:\Inetpub\vhosts\*domain*\httpdocs\aspnet_client: An ACE for user *username* for this folder and subfolders with access mask 1200A9 needed by Plesk cannot be found in the existing DACL

    It appears that ASP.NET is quite screwed up on my system, eh? The problems still exist after running the reconfigurator.

    Any ideas?
     
  6. OlegB

    OlegB Guest

    0
     
    I can suggest you to reinstall ASP.NET. May be user ASPNET is removed from the system?
    Then reconfigure vhosts security using Plesk reconfigurator.
     
  7. FFCus

    FFCus Guest

    0
     
    Thanks Oleg, further investigation showed that sites running .NET 1.1 were fine, the issue was only with the sites using 2.0

    After I repaired the 2.0 installation - all was good.
     
Loading...