1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

anonymous@host.com with Front Page Forms

Discussion in 'Plesk for Linux - 8.x and Older' started by Piggie, Apr 16, 2005.

  1. Piggie

    Piggie Guest

    All my FP forms send email from anonymous@host.com, not the person sending the email. I know the forms worked on a W2K server and Linux running an Ensim Panel. I moved to Plesk and now they are all from anonymous@host.com.

    I tried modifing the fp extentions but that didn't work. maybe I did it wrong.

    anyone have any ideas?
  2. hardweb

    hardweb Guest

    You must inject the return path for qmail. If you post the code that sends the email I might be able to tell you how to do this.
  3. Piggie

    Piggie Guest

    Thank you, I think I see the problem, maybe.
    The server I was on before used a generic version of sendmail, and maybe qmail responds different to FP email forms? I am guessing, but at all sure with my limited experience.

    Here is the fix I tried first that didn't work.
    a.. FrontPage sends e-mail on behalf of user anonymous@host. How can I set up an arbitrary sender's name?
    a.. You need to modify the configuration file /usr/local/psa/frontpage/domain.com:80.cnf as follows:

    Add the following lines:


    Remove the line sendmailcommand:/usr/local/psa/qmail/bin/sendmail

    Note that these settings will be applicable only to this domain.

    If you wish to apply the settings to all domains, you should edit the global FrontPage configuration file located at /usr/local/frontpage/version5.0/frontpage.cnf

    that didn't work.

    Here is the script of my form.


    <form METHOD="POST" action="--WEBBOT-SELF--" name="FrontPage_Form1" onsubmit="return FrontPage_Form1_Validator(this)" language="JavaScript">
    <!--webbot bot="SaveResults" startspan
    U-File="../_private/user/mail.txt" S-Format="TEXT/PRE"
    S-Label-Fields="TRUE" B-Reverse-Chronology="FALSE"
    U-File="../birdclan.htm" S-Format="HTML/BR" S-Label-Fields="TRUE"
    B-Reverse-Chronology="TRUE" S-Email-Format="HTML/PRE"
    B-Email-Label-Fields="TRUE" B-Email-ReplyTo-From-Field="TRUE"
    S-Email-ReplyTo="Email" B-Email-Subject-From-Field="TRUE"
    S-Email-Subject="Subject" S-Date-Format="%m/%d/%y"
    S-Time-Format="%H:%M" S-Builtin-Fields="REMOTE_NAME Date Time"
    S-Email-Address="me@mydomain.com" --><input TYPE="hidden" NAME="VTI-GROUP" VALUE="0"><!--webbot
    bot="SaveResults" endspan -->
    <div align="center">
    <table border="0" cellpadding="0" cellspacing="0" width="100%">
    <td align="center"><font face="Times New Roman" size="5">Send
    ME an Email with this form</font></td>
    <td align="center">An <b><font color="#FF0000" size="5">*</font></b>
    denotes a required field</td>
    <td align="center"><i>Webmasters wanting to trade links<br>
    do not use this form, instead <a href="../links/index.htm#linktous">click
    <div align="center">
    <table width="100%">
    <td ALIGN="center" width="15%"><b><font size="2"> Name</font><font color="#FF0000" size="5">*</font></b></td>
    <td width="80"><!--webbot bot="Validation"
    S-Display-Name="First Name" S-Data-Type="String"
    B-Value-Required="TRUE" I-Minimum-Length="1" --><input NAME="Name" SIZE="25"></td>
    <td ALIGN="center" width="15%"><font size="2"><b>Your E-mail</b></font><b><font color="#FF0000" size="5">*</font></b></td>
    <td width="80%"><!--webbot bot="Validation"
    S-Display-Name="Your Email Address" S-Data-Type="String"
    B-Value-Required="TRUE" I-Minimum-Length="1" --><input NAME="Email" SIZE="30"></td>
    <td ALIGN="center" width="15%"><font size="2"><b>Phone Number</b></font></td>
    <td width="80%"><input NAME="Phone_Number" SIZE="25"></td>
    <td ALIGN="center" width="15%"><font size="2"><b>Subject</b></font><b><font color="#FF0000" size="5">*</font></b></td>
    <td width="80%"><!--webbot bot="Validation"
    S-Display-Name="Subject of the Message"
    B-Value-Required="TRUE" --><select size="1" name="Subject">
    <option selected>Information</option>
    <option>Sales Question</option>
    <option>Report a Bad Link</option>
    <td ALIGN="center" width="15%"><font size="2"><b>Comments</b></font><b><font color="#FF0000" size="5">*</font></b></td>
    <td width="80%"><!--webbot bot="Validation"
    S-Display-Name="Body of the Message (Comments)"
    B-Value-Required="TRUE" --><textarea rows="10" name="Comments" cols="50" WRAP="VIRTUAL" style="font-size: 10pt; font-weight: bold; border-style: inset"></textarea></td>
    <p align="center"><input TYPE="SUBMIT" VALUE="Submit Form"> <input TYPE="RESET" VALUE="Reset Form"></p>


    Thank you
  4. Piggie

    Piggie Guest

    I want to add that the hint I found at rtr.com won't work on Plesk Reloaded or it seems.

    The command lines:


    Don't appear to even be read by Reloaded in the domain.com:80.cnf file, even with the
    sendmailcommand: line removed.

    If what I read was true in older versions of Plesk (presuming before Reloaded), and
    this used to work.

    Just thought I would throw that in that I had tried to fix the problem that way also.

    If you find a way to alter the format of a Front Page form to send Reloaded what it wants I will be forever grateful hardweb.

  5. worker

    worker Guest

    For the benefit of the community, this seems to work:

    bash-2.05b# grep /usr/local/frontpage/domain.com\:80.cnf -e ^sendmailcommand
    sendmailcommand:/usr/lib/sendmail -F Name_here -f user@domain.com
  6. Piggie

    Piggie Guest

    That is what I ended up doing. I don't call it a fix, its just more palatable and easier to read than the way it was before. This is what I did:

    I modified the line of the file:


    sendmailcommand:/var/qmail/bin/sendmail -F NameOfMySite -f main-email@specificdomain.com

    The result is better than it was and mail arrives now as

    from: "NameOfMySite" <anonymous@admin.mainpleskserverdomain.com>

    If you look in the headers or raw view of the email you also see:

    Return-Path: <main-email@specificdomain.com>

    From what I can tell this is the best work around possible.
    I still firmly beleive, since I have seen my forms work on other Linux control panel systems
    that a totaly correct solution should format the from in the email to:

    "NameOfMySite" <main-email@specificdomain.com>

    and not the anonymous@admin.mainpleskserverdomain.com

    Ok, I have said my peace. Hopefully someone from Plesk will find this and consider a fix in version 8.
  7. jamesyeeoc

    jamesyeeoc Guest

    Since the other server(s) you used were running Sendmail, and Plesk uses Qmail which do handle email a bit differently, it is an issue which should be taken up with the authors of Qmail. Plesk (sw-soft) will most likely not see it as their problem since they did not write the Qmail code.

    Differences between Qmail and Sendmail have been bantied about here during many, many versions of Plesk. The bottom line is: if you don't like how Qmail operates, then you better consider switching off of Plesk since it doesn't appear that SwSoft will change off of Qmail.....
  8. Piggie

    Piggie Guest

    Yes, I have come to that conclusion my self and thank you for re-enforcing it. I am not having much better luck installing MailWasher Server either because of Qmail.

    Now before any one gets the wrong idea, my programing skills don't allow me to say sendmail or qmail are better.

    But I can say intergrating other programs into qmail that were written for sendmail is at best a challenge and at worst a hopeless case.

    Hopefully as time passes other third party software will become more qmail friendly or visa versa (so I don't step on anyone's toes).

    Thanks everyone for your help.

    On to my next project........