1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Apache 2.2 high usage (wan't mpm worker in stead of prefork).

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by zyxep, Nov 1, 2011.

  1. zyxep

    zyxep Guest

    0
     
    Hi.

    first of all i say the specs of the server.
    CPU: intel i7-920
    MEM: 8GB DDR3
    HDD: 2x750 GB software raid-1
    OS: Debian 6
    Plesk 10.3

    i an the server administrator and i got a mail from the plesk system about apache memory usage, going from green to red and yellow and then green.

    i did see with "apache2 -l" that it has loaded prefork and i wan't worker, but when i do "apt-get install apache2-mpm-worker" it will delete many plesk related programs.


    # apt-get install apache2-mpm-worker
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libdevel-symdump-perl sw-librrd bind9 sharutils sw-rrdtool psa-pear re2c bind9utils
    pp-sitebuilder-default-templates php5-sqlite sw-sso libapache2-reload-perl spamc php5-curl psa-ftputil
    libbsd-resource-perl psa-locale-base-en-us libapache2-mod-perl2 webalizer php5-imap psa-logrotate php5-mysql
    libnetaddr-ip-perl libmail-spf-perl plesk-skins sw-collectd pp-sitebuilder-skins psa-proftpd python-libxml2
    spamassassin sw-doctrine
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    apache2-mpm-prefork libapache2-mod-php5 plesk-billing plesk-core plesk-l10n pp-sitebuilder psa psa-atis
    psa-atmail psa-backup-manager psa-fileserver psa-firewall psa-health-monitor psa-horde psa-imp psa-ingo
    psa-kronolith psa-migration-agents psa-migration-manager psa-mimp psa-mnemo psa-passwd psa-php5-configurator
    psa-spamassassin psa-turba psa-updates psa-vhost sshterm
    The following NEW packages will be installed:
    apache2-mpm-worker
    0 upgraded, 1 newly installed, 28 to remove and 0 not upgraded.
    Need to get 2.240 B of archives.
    After this operation, 600 MB disk space will be freed.
    Do you want to continue [Y/n]? ^C


    is there a way how i can get apache2-mpm-worker on my system with plesk 10.3?
     
  2. thekman

    thekman Guest

    0
     
    oomguarpages resource alerts

    Not sure if it's related but since the update I have been having a nightmare with our server running really slow when serving up pages. I have been told by my web host that Apache might be to blame having high usage. They pointed me at the resource alerts section of Virtuozzo as since the update to 10.3.1 I have been seeing oomguarpages Red zone errors appearing. Can you confirm if you have similar errors in your Virtuozzo panel?

    Thanks.
     
  3. zyxep

    zyxep Guest

    0
     
    i doesn't use Virtuozzo to my server.
     
Loading...