1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

apache not parsing php script

Discussion in 'Plesk for Linux - 8.x and Older' started by abubin, Jan 24, 2009.

  1. abubin

    abubin Guest

    0
     
    My server suddenly refuse to run php scripts. When I go to any php files, it will ask me to download the file application/x-httpd-php.

    php already running fine. Did nothing to it except install plesk toys few days ago. Was working fine after plesk toys was installed.

    I restarted apache tons and rebooted the server still facing this problem.

    I command line, I type php -v and i do get php version showing.

    Any idea how to fix this? All php sites are not functioning now!! Please it's urgent!! Thank you very much.
     
  2. vaida.dan

    vaida.dan Guest

    0
     
    Did you check to see which modules are loaded in apache ? Try to see if the php module is set to load.
    Also, you might want to check out /etc/apache/httpd.conf and make sure you have support for index.php files in DirectoryIndex:

    <IfModule mod_dir.c>
    DirectoryIndex index.html index.htm index.shtml index.cgi index.php
    </IfModule>
     
  3. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    make sure this exists in your httpd.conf file
    DirectoryIndex wouldnt be your problem, it seems that the issue is related to MIME types as the server doesnt know what kind of file it is and doesnt know how to dislpay it.

    Also make sure you dont have any vhost.conf or httpd.include files that are taking those mime types out
    Something such as suphp or something similar remove those mime types and if its not working properly (assuming its even installed) could also be the issue.
     
  4. abubin

    abubin Guest

    0
     
    Thanks for all the replies.

    After hours of checking logs and configs and restarting apache for countless times, found out that problem is due to suPHP.

    This suPHP was configured long time ago and was already working fine. I don't know why suddenly it just refuse to work. It is now disabled. Will check it later to see what was wrong.
     
  5. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    You have updated maybe and the new configuration is not compatible anymore, new version require new settings.
     
Loading...