1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

App Vault apps install with incorrect PHP Handler

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by SamVW, Oct 7, 2011.

  1. SamVW

    SamVW Guest

    0
     
    We are running Plesk 10.3. Whenever we install an app from the App Vault (Wordpress, Drupal, etc.) the IIS Application is created with the PHP handler mapping of "Custom-php" which is an Isapi filter. The actual sites in question are all set up to use FastCGI. The Isapi apparently doesn't work because it causes a 500 error. The only way to resolve this (that I've found) is to manually go into IIS and change the handler on the IIS Application to FastCGI.

    This isn't a problem with IIS. When we manually add an IIS Application in IIS it is created with the correct FastCGI handler. Plesk is somehow stripping this and adding its own.

    Is this a setting I'm missing somewhere, or should this turn into a support ticket?
     
  2. SamVW

    SamVW Guest

    0
     
    Additionally, the apps are being installed with Register Globals turned on in the registry, which we then have to manually turn off.

    The app vault is basically worthless to us right now because of this. Nobody has any insight at all?

    Server 2008
    x64
    Plesk 10.3.1
     
Loading...